Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: PDI 7, Amazon AMI, and webkit

  1. #1
    Join Date
    Dec 2016
    Posts
    8

    Default PDI 7, Amazon AMI, and webkit

    Hi,

    I am currently in the process of upgrading to Pentaho 7 on an Amazon instance and in the installation guide it says that linux users need to download libwebkitgtk-1.0-0. I am having trouble finding a way to download this onto the instance. I have tried yum and the package does not exist and google is not helping much. How can I resolve this issue?

    Thank you

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    Try a resource finder (e.g. rpmfind.net) to download and install the package you need.

    Happy New Year
    So long, and thanks for all the fish.

  3. #3
    Join Date
    Dec 2016
    Posts
    8

    Default

    That is the issue though. There is no clear package that I should install. All the packages I see that have libwebkitgtk-1.0-0 are for different distros than Amazon AMI. I am unsure which one to download. The packages might also not have all the dependencies I need specifically when running on Amazon AMI.

  4. #4
    Join Date
    Dec 2016
    Posts
    8

    Default PDI 7, Amazon AMI, and webkit

    Hi,

    I am trying to upgrade to Pentaho DI 7 on an Amazon AMI instance and in the installation guide it says that linux users need to download libwebkitgtk-1.0-0. I am having trouble finding a way to download this onto the instance. I have tried yum and the package does not exist and google is not helping much. How can I resolve this issue? I asked this question a few months back and did not receive any replies that gave a complete solution to the issue.

    Thank you

  5. #5
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Are you planning on running spoon in the AMI?
    If not, then you shouldn't need libwebkitgtk. GTK is part of the GUI

  6. #6
    Join Date
    Dec 2016
    Posts
    8

    Default

    Yes, I am planning on running spoon in the AMI.

  7. #7
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    You are planning on running the GUI Designer in your AMI?
    Ok...
    You may have some severe digging (and perhaps compiling) ahead of you...

  8. #8
    Join Date
    Dec 2016
    Posts
    8

    Default

    We might be thinking of spoon as two different things in this instance. I am talking about spoon.sh being called by kitchen.sh and pan.sh.

  9. #9
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Pan and Kitchen are distinct shell programs, and indicate that to spoon.sh (I *REALLY* wish they hadn't done that) that they are command line programs.

    Since you're not running a GUI, you should be fine without libwebkitgtk.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.