Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Cube Publishing Error

  1. #1
    Join Date
    Jan 2017
    Posts
    1

    Thumbs up Cube Publishing Error

    I've been having problems viewing my cube. I'm using Pentaho BI Server 4.8.0-stable, Schema Workbench 3.2.2-stable, jdk 1.7.0_79, on Windows 10.

    My desired result is a cube with one fact dimension, and three additional dimensions. One of these dimension being a Time dimension, including month and year. My cube publishes fine, viewing it on Pentaho is a problem.


    The xml code:
    <Schema name="Recall">
    <Cube name="Cubo Recalls" cache="true" enabled="true">
    <Table name="fato_campanha_recall" schema="public" alias="Fato Campanha Recall">
    </Table>
    <Dimension type="StandardDimension" foreignKey="empresa_chave" highCardinality="false" name="Empresa">
    <Hierarchy name="Empresa" hasAll="true">
    <Table name="empresa" schema="public" alias="Empresa">
    </Table>
    <Level name="Fornecedor" column="fornecedor" type="String" uniqueMembers="false" levelType="Regular" hideMemberIf="Never">
    </Level>
    </Hierarchy>
    </Dimension>
    <Dimension type="StandardDimension" foreignKey="produto_recall_chave" highCardinality="false" name="Produto_Recall">
    <Hierarchy name="Produto_Recall" hasAll="true">
    <Table name="produto_recall" schema="public" alias="Produto_Recall">
    </Table>
    <Level name="Assunto" column="assunto" type="String" uniqueMembers="false" levelType="Regular" hideMemberIf="Never">
    </Level>
    <Level name="Classificacao" column="classificacao" type="String" uniqueMembers="false" levelType="Regular" hideMemberIf="Never">
    </Level>
    <Level name="Objeto" column="objeto" type="String" uniqueMembers="false" levelType="Regular" hideMemberIf="Never">
    </Level>
    <Level name="Defeito" column="defeito" type="String" uniqueMembers="false" levelType="Regular" hideMemberIf="Never">
    </Level>
    </Hierarchy>
    </Dimension>
    <Dimension type="TimeDimension" foreignKey="tempo_chave" highCardinality="false" name="Tempo">
    <Hierarchy name="Tempo" hasAll="true">
    <Table name="tempo" schema="public" alias="Tempo">
    </Table>
    <Level name="Mes" column="mes" ordinalColumn="mes" type="Numeric" uniqueMembers="false" levelType="TimeMonths" hideMemberIf="Never">
    </Level>
    <Level name="Ano" column="ano" ordinalColumn="ano" type="Numeric" uniqueMembers="false" levelType="TimeYears" hideMemberIf="Never">
    </Level>
    </Hierarchy>
    </Dimension>
    <Measure name="Quantidade_Afetados" column="quantidade_afetados" datatype="Integer" formatString="#,###" aggregator="sum" visible="true">
    </Measure>
    <Measure name="Quantidade_Atendidos" column="quantidade_atendidos" datatype="Numeric" formatString="#,###" aggregator="sum" visible="true">
    </Measure>
    </Cube>
    </Schema>




    Pentaho.log:

    2017-01-02 15:46:38,381 WARN [org.pentaho.hadoop.shim.HadoopConfigurationLocator] Unable to load Hadoop Configuration from "file:///C:/pentaho/biserver-ce/pentaho-solutions/system/kettle/plugins/pentaho-big-data-plugin/hadoop-configurations/mapr". For more information enable debug logging.
    2017-01-02 15:46:41,329 WARN [org.pentaho.reporting.libraries.base.boot.PackageManager] Unresolved dependency for package: org.pentaho.reporting.engine.classic.extensions.datasources.cda.CdaModule
    2017-01-02 15:46:41,460 WARN [org.pentaho.reporting.libraries.base.boot.PackageSorter] A dependent module was not found in the list of known modules.
    2017-01-02 15:46:59,917 WARN [org.apache.commons.httpclient.HttpMethodBase] Going to buffer response body of large or unknown size. Using getResponseBodyAsStream instead is recommended.
    2017-01-02 15:47:03,511 WARN [org.apache.axis2.description.java2wsdl.DefaultSchemaGenerator] We don't support method overloading. Ignoring [public java.lang.String serializeModels(org.pentaho.metadata.model.Domain,java.lang.String,boolean) throws java.lang.Exception]
    2017-01-02 15:50:50,925 WARN [org.pentaho.platform.engine.services.runtime.TemplateUtil] not found: [Measures].[Quantidade_Afetados]



    Any and all suggestions are welcome. I'm new to Pentaho so please be as detailed as possible
    Attached Images Attached Images  

  2. #2
    Join Date
    Nov 2009
    Posts
    688

    Default

    Why are you using such a old version of Pentaho when you are starting with Pentaho?
    Is it possible to view cubes delivered by Pentaho like the SampleData or SteelWheels Schema?
    There is also a logging in ..\biserver-ce\pentaho-solutions\system\logs\audit\. What is that telling you?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.