Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Getting error while setting the variable value from Parameter.

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Getting error while setting the variable value from Parameter.

    Hi,

    Can someone help me to why I am getting this sort of error.

    XML file [file:///etljobs/wealth-marketing/email-growth/AddMissingAdvisersFromFirmAllocation.ktr]
    2017/01/05 00:00:38 - AddMissingAdvisersFromFirmAllocation - Dispatching started for transformation [AddMissingAdvisersFromFirmAllocation]
    2017/01/05 00:00:43 - Execute SQL To Add Missing RIs.0 - Finished reading query, closing connection.
    2017/01/05 00:00:43 - Execute SQL To Add Missing RIs.0 - Finished processing (I=0, O=0, R=0, W=1, U=0, E=0)
    2017/01/05 00:00:43 - Dummy (do nothing).0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
    2017/01/05 00:00:43 - EmailGrowth - Starting entry [Deduce Email Addresses]
    2017/01/05 00:00:43 - Deduce Email Addresses - Loading transformation from XML file [file:///etljobs/wealth-marketing/email-growth\DeduceEmailAddresses.ktr]
    2017/01/05 00:00:43 - DeduceEmailAddresses - Dispatching started for transformation [DeduceEmailAddresses]
    Continue (enter "y" for yes, "n" for no)?
    2017/01/05 00:07:21 - Execute SQL to Deduce email addresses.0 - Finished reading query, closing connection.
    2017/01/05 00:07:21 - Execute SQL to Deduce email addresses.0 - Finished processing (I=0, O=0, R=0, W=1, U=0, E=0)
    2017/01/05 00:07:21 - Dummy (do nothing).0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
    2017/01/05 00:07:21 - EmailGrowth - Starting entry [Create output folder if it doesn't exist]
    2017/01/05 00:07:21 - Set variables - ERROR (version 5.0.1-stable, build 1 from 2013-11-15_16-08-58 by buildguy) : Could not create Folder [/dataload//WETL/Dropzone/Marketing/email-growth/outbound/]
    2017/01/05 00:07:21 - Set variables - ERROR (version 5.0.1-stable, build 1 from 2013-11-15_16-08-58 by buildguy) : org.apache.commons.vfs.FileSystemException: Could not create folder "file:///dataload/WETL/Dropzone/Marketing/email-growth".
    2017/01/05 00:07:21 - Set variables - at
    org.apache.commons.vfs.provider.AbstractFileObject.createFolder(Unknown Source)
    2017/01/05 00:07:21 - Set variables - at org.apache.commons.vfs.provider.AbstractFileObject.createFolder(Unknown Source)
    2017/01/05 00:07:21 - Set variables - at org.pentaho.di.job.entries.createfolder.JobEntryCreateFolder.execute(JobEntryCreateFolder.java:199)
    2017/01/05 00:07:21 - Set variables - at org.pentaho.di.job.Job.execute(Job.java:678)
    2017/01/05 00:07:21 - Set variables - at org.pentaho.di.job.Job.execute(Job.java:815)
    2017/01/05 00:07:21 - Set variables - at org.pentaho.di.job.Job.execute(Job.java:815)
    2017/01/05 00:07:21 - Set variables - at org.pentaho.di.job.Job.execute(Job.java:815)
    2017/01/05 00:07:21 - Set variables - at org.pentaho.di.job.Job.execute(Job.java:815)
    2017/01/05 00:07:21 - Set variables - at org.pentaho.di.job.Job.execute(Job.java:815)
    2017/01/05 00:07:21 - Set variables - at org.pentaho.di.job.Job.execute(Job.java:500)
    2017/01/05 00:07:21 - Set variables - at org.pentaho.di.job.Job.run(Job.java:407)
    2017/01/05 00:07:21 - Set variables - Caused by: org.apache.commons.vfs.FileSystemException: Could not create directory "/dataload/WETL/Dropzone/Marketing/email-growth".
    2017/01/05 00:07:21 - Set variables - at org.apache.commons.vfs.provider.local.LocalFile.doCreateFolder(Unknown Source)
    2017/01/05 00:07:21 - Set variables - ... 11 more


    The solution I have tried but unfortunately not working:

    1. Error is not related to the double slash "//" present in the path.

    2. In the job I am trying to set this value (/dataload//WETL/Dropzone/Marketing/email-growth/outbound/) to a variable and after few transformation in the job I am checking if the path actually exists or not before loading the data to outbound directory, if not then it creates a directory the the location.

    3. At this point I am thinking that this is related to the permission related error while setting the directory at the path.

    Can someone help me to sort this thing out ??

    -------------------------------
    pdi-ce-6.0.1.0-386-stable
    java 1.8.0_101
    Window 7 (x86_64)
    timezone IST
    --------------------------

    Thanks in Advance,
    G_nish
    Last edited by Nishank Goel; 01-09-2017 at 10:11 AM. Reason: formatting

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.