Hi,

I'm attempting to read folder full of xlsm files. However, 2 of the 21 XLSM files I'm trying to read present messages like this:

Invalid header signature; read 0x74776572646E610E, expected 0xE11AB1A1E011CFD0 - Your file appears not to be a valid OLE2 document

Clearly there is something not right about the file headers. I have tried re-saving the files, and saving as xlsb and re-saving as xlsm without success. Any thoughts as to what I can do to correct this behavior? I can think about stripping out the vba content and saving these as xlsx files but I feel like this shouldn't be necessary.

I've read a stack overflow post here which suggests that adding some specific Jar files to my Java path might a way to resolve this.

http://stackoverflow.com/questions/1...mework-in-java

However on that note I worry about my Java path not being set up right. I have this message when loading PDI:

Name:  pentaho_java.jpg
Views: 2259
Size:  17.7 KB

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

I think that this is my java path info:

Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.


C:\WINDOWS\system32>for %i in (java.exe) do @echo. %~$PATH:i
C:\ProgramData\Oracle\Java\javapath\java.exe


C:\WINDOWS\system32>


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
This is what I currently have set for java path in my spoon.bat file:



REM Special console/debug options when called from SpoonConsole.bat or SpoonDebug.bat
if "%SPOON_CONSOLE%"=="1" set PENTAHO_JAVA=C:\Program Files\Java\jre1.8.0_112\bin\java.exe
if not "%SPOON_CONSOLE%"=="1" set PENTAHO_JAVA=C:\Program Files\Java\jre1.8.0_112\bin\javaw.exe
set IS64BITJAVA=0


call "%~dp0set-pentaho-env.bat"