Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Spoon.bat doesnt start

  1. #1

    Default Spoon.bat doesnt start

    Hi Everyone,

    When i try to start the spoon.bat file the kettle doesnt show up. Below is the error message

    C:\Users\Ramesh>C:\Users\Ramesh\Documents\pdce\pdi-ce-7.0.0.0-25\data-integration\Spoon.bat
    DEBUG: Using JAVA_HOME
    DEBUG: _PENTAHO_JAVA_HOME=C:\Program Files (x86)\Java\jre1.8.0_121
    DEBUG: _PENTAHO_JAVA=C:\Program Files (x86)\Java\jre1.8.0_121\bin\javaw.exe

    C:\Users\Ramesh\Documents\pdce\pdi-ce-7.0.0.0-25\data-integration>start "Spoon" "C:\Program Files (x86)\Java\jre1.8.0_121\bin\javaw.exe" "-Xms1024m" "-Xmx2048m" "-XX:MaxPermSize=256m" "-Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2" "-Djava.library.path=libswt\win32" "-DKETTLE_HOME=" "-DKETTLE_REPOSITORY=" "-DKETTLE_USER=" "-DKETTLE_PASSWORD=" "-DKETTLE_PLUGIN_PACKAGES=" "-DKETTLE_LOG_SIZE_LIMIT=" "-DKETTLE_JNDI_ROOT=" -jar launcher\pentaho-application-launcher-7.0.0.0-25.jar -lib ..\libswt\win32


    System Variables: JAVA_HOME - C:\Program Files (x86)\Java\jre1.8.0_121
    PENTAHO_JAVA - C:\Program Files (x86)\Java\jre1.8.0_121\bin\javaw.exe

    I Use windows10 64 bit machine.
    After reading the forums i added another system variable called CLASSPATH - %JAVA_HOME%\lib

    Please let me know a possible solution

  2. #2
    Join Date
    Feb 2017
    Posts
    3

    Default

    Hi Santosh,

    I am facing a similar problem and posted it on this platform for assistance. So far no response from anyone. I will let you know when I get a solution.

    Best regards,

  3. #3
    Join Date
    Feb 2017
    Posts
    3

    Default

    Dear Santosh,

    Trust you are doing well. I have been able to resolve my issue and PDI CE 7 is now running. Below are the steps that worked for me:

    1. I deleted the PDI I installed
    2. I maintained the environment variables I set up for the previous installation
    3. Downloaded PDI CE 7 again
    4. Extracted the file
    5. Created the Pentaho/design-tools in the C/Program Files directory
    6. Copied and pasted the data-integration file extracted from the zipped file in step 4 into the design-tools folder
    7. Double clicked on the spoon bat icon and PDI CE7 was up and running.

    Try it and let me know whether it works for you.

    Regards,

  4. #4
    Join Date
    Nov 2009
    Posts
    688

    Default

    The problem by Santos is that he is using the 32 bits version of Java. See DEBUG: _PENTAHO_JAVA_HOME=C:\Program Files (x86)\Java\jre1.8.0_121
    Program Files (x86) indicates that it is a 32 bits program. The 32 bits version of Java can't address the Xmx2048 so you have to lower that to Xmx 1536 or lower

  5. #5

    Default

    Problem solved! Executed set PENTAHO_JAVA_HOME=c:\Program Files\Java\jdk1.8.0_121
    This solved my issue.

  6. #6
    Join Date
    Oct 2010
    Posts
    24

    Default

    Some problem solved, but kettle still has error when started it:
    INFO: New Caching Service registered
    10:41:30,037 ERROR [KarafLifecycleListener] Error in Feature Watcher
    org.pentaho.osgi.api.IKarafFeatureWatcher$FeatureWatcherException: Unknown error in KarafWatcher
    at org.pentaho.osgi.impl.KarafFeatureWatcherImpl.waitForFeatures(KarafFeatureWatcherImpl.java:125)
    at org.pentaho.di.osgi.KarafLifecycleListener$2.run(KarafLifecycleListener.java:144)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: org.pentaho.osgi.api.IKarafFeatureWatcher$FeatureWatcherException: Timed out waiting for Karaf features to install: config,pentaho-client,pentaho-metaverse,pdi-dataservice,pdi-data-refinery
    at org.pentaho.osgi.impl.KarafFeatureWatcherImpl.waitForFeatures(KarafFeatureWatcherImpl.java:154)
    at org.pentaho.osgi.impl.KarafFeatureWatcherImpl.waitForFeatures(KarafFeatureWatcherImpl.java:97)
    ... 2 more
    2017/05/05 10:41:32 - General - ERROR (version 7.0.0.0-25, build 1 from 2016-11-05 15.35.36 by buildguy) : Error starting Spoon shell
    2017/05/05 10:41:32 - General - ERROR (version 7.0.0.0-25, build 1 from 2016-11-05 15.35.36 by buildguy) : java.lang.ExceptionInInitializerError
    2017/05/05 10:41:32 - General - at org.pentaho.di.ui.spoon.Spoon.init(Spoon.java:845)
    2017/05/05 10:41:32 - General - at org.pentaho.di.ui.spoon.Spoon.createContents(Spoon.java:9256)
    2017/05/05 10:41:32 - General - at org.eclipse.jface.window.Window.create(Window.java:426)
    2017/05/05 10:41:32 - General - at org.eclipse.jface.window.Window.open(Window.java:785)
    2017/05/05 10:41:32 - General - at org.pentaho.di.ui.spoon.Spoon.start(Spoon.java:9287)
    2017/05/05 10:41:32 - General - at org.pentaho.di.ui.spoon.Spoon.main(Spoon.java:685)
    2017/05/05 10:41:32 - General - at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    2017/05/05 10:41:32 - General - at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    2017/05/05 10:41:32 - General - at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    2017/05/05 10:41:32 - General - at java.lang.reflect.Method.invoke(Method.java:498)
    2017/05/05 10:41:32 - General - at org.pentaho.commons.launcher.Launcher.main(Launcher.java:92)
    2017/05/05 10:41:32 - General - Caused by: java.util.MissingResourceException: Can't find bundle for base name ui/laf, locale en_US
    2017/05/05 10:41:32 - General - at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1564)
    2017/05/05 10:41:32 - General - at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1387)
    2017/05/05 10:41:32 - General - at java.util.ResourceBundle.getBundle(ResourceBundle.java:1082)
    2017/05/05 10:41:32 - General - at org.pentaho.di.ui.spoon.XulSpoonResourceBundle.<clinit>(XulSpoonResourceBundle.java:65)
    2017/05/05 10:41:32 - General - ... 11 more
    stopping


    Thanks for any help.

    Jenny
    Last edited by qding2008; 05-04-2017 at 06:50 PM. Reason: old problem was solved

  7. #7
    Join Date
    Oct 2010
    Posts
    24

    Default

    Problem solved since re-unzip files.

  8. #8

    Default

    hello,
    Sorry same error.
    WARNING: Using java from path
    DEBUG: _PENTAHO_JAVA_HOME=
    DEBUG: _PENTAHO_JAVA=javaw.exe
    The system cannot find the path specified.
    The system cannot find the path specified.


    C:\kettle\data-integration>start "Spoon" "javaw.exe" "-Xms1024m" "-Xmx2048m" "-
    XX:MaxPermSize=256m" "-Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2" "-Djava.library.p
    ath=libswt\win32" "-DKETTLE_HOME=" "-DKETTLE_REPOSITORY=" "-DKETTLE_USER=" "-DKE
    TTLE_PASSWORD=" "-DKETTLE_PLUGIN_PACKAGES=" "-DKETTLE_LOG_SIZE_LIMIT=" "-DKETTLE
    _JNDI_ROOT=" -jar launcher\pentaho-application-launcher-7.0.0.0-25.jar -lib ..\l
    ibswt\win32

    I have a 64bit
    Last edited by michaelmastantuono; 05-05-2017 at 05:41 PM. Reason: adding content

  9. #9
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Michael,
    You have a bad path to Java.
    Make sure that your OS variable JAVA_HOME points to a valid 64bit Java.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.