Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: PDI starting ... Unrecognized option: Xmx1024M

  1. #1

    Default PDI starting ... Unrecognized option: Xmx1024M

    Hello all,

    I'm not able to start Spoon.bat
    I did the log test and the result is the following.
    Unfortunately I'm not a technician and I got difficult to interpret it . Many thanks

    DEBUG: Using PENTAHO_JAVA_HOME
    DEBUG: _PENTAHO_JAVA_HOME=C:\Program Files (x86)\Java\jre1.8.0_121
    DEBUG: _PENTAHO_JAVA=C:\Program Files (x86)\Java\jre1.8.0_121\bin\java.exe


    C:\DATA_SYNCRO\data-integration>"C:\Program Files (x86)\Java\jre1.8.0_121\bin\java.exe" "-Xmx2048m" "-XX:MaxPermSize=1024m" "-Dhttps.protocols=TLSv1,TLSv1.1,TLSv1.2" "-Djava.library.path=libswt\win32" "-DKETTLE_HOME=" "-DKETTLE_REPOSITORY=" "-DKETTLE_USER=" "-DKETTLE_PASSWORD=" "-DKETTLE_PLUGIN_PACKAGES=" "-DKETTLE_LOG_SIZE_LIMIT=" "-DKETTLE_JNDI_ROOT=" -jar launcher\pentaho-application-launcher-7.0.0.0-25.jar -lib ..\libswt\win32 /levelebug
    Error: Could not create the Java Virtual Machine.
    Error: A fatal exception has occurred. Program will exit.
    Java HotSpot(TM) Client VM warning: ignoring option MaxPermSize=1024m; support was removed in 8.0
    Picked up _JAVA_OPTIONS: Xmx1024M
    Unrecognized option: Xmx1024M

  2. #2
    Join Date
    Feb 2017
    Posts
    18

    Default

    if you changed anything on your spoon.bat manually than open it again. You have multiple options in that file one should look similar to this:
    if "%PENTAHO_DI_JAVA_OPTIONS% "==""set PENTAHO_DI_JAVA_OPTIONS="-Xms1024m" "-Xmx4096m" "-XX:MaxPermSize=512m" for me this is line 94 in the .bat file btw. I hope this helps.

  3. #3

    Default

    Thanks , I will try next time I go to customer but I think there are some incompatibility with 64 bit and 32 bit java / PDI

  4. #4
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    Quote Originally Posted by Giovanni View Post
    Picked up _JAVA_OPTIONS: Xmx1024M
    Unrecognized option: Xmx1024M
    The switch character (-) is missing - it must be -Xmx1024m.
    Check your environment variables.
    So long, and thanks for all the fish.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.