Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Error trying to get a variable value

  1. #1
    Join Date
    Nov 2013
    Posts
    382

    Default Error trying to get a variable value

    Just trying to get the value of ${user.home} and no way Get session variables step returns its value:

    Code:
    2017/03/09 15:23:59 - Get session variables.0 - Get session variable [C:\Users\MyUser] = []
    2017/03/09 15:23:59 - Get session variables.0 - ERROR (version 7.0.0.0-25, build 1 from 2016-11-05 15.35.36 by buildguy) : Unexpected error
    2017/03/09 15:23:59 - Get session variables.0 - ERROR (version 7.0.0.0-25, build 1 from 2016-11-05 15.35.36 by buildguy) : org.pentaho.di.core.exception.KettleValueException: 
    2017/03/09 15:23:59 - Get session variables.0 - my_field None : I can't convert the specified value to data type : 0
    Seems a similar case to this closed Jira case http://jira.pentaho.com/browse/PDI-13787 fixed in 7.0.0 GA

    We are using Version 7.0.0.0-25 , shouldn't it be ok?

  2. #2
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    ${user.home} isn't a session variable, it's just a variable. Get it with Get Variables

    Also, the Get Session Variables step is expecting the variable name, not the ${}, which is why you are getting C:\Users\MyUser in the variable name location. Though the documentation at http://wiki.pentaho.com/display/EAI/...sion+Variables suggests that how you are using it is correct.
    Last edited by gutlez; 03-09-2017 at 12:25 PM.

  3. #3
    Join Date
    Nov 2013
    Posts
    382

    Default

    aahhhhrgggg thks gutlez

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.