Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Pentaho Report Designer crosstab is not grouping columns properly

  1. #1
    Join Date
    Apr 2017
    Posts
    2

    Default Pentaho Report Designer crosstab is not grouping columns properly

    I was creating a crosstab in Pentaho Report Designer 7.0 and expeting output like this,
    Name:  Screen Shot 2017-04-05 at 12.24.26 PM.jpg
Views: 514
Size:  9.7 KB

    Unfortunately, I am getting output as below,
    Name:  Screen Shot 2017-04-05 at 12.26.46 PM.jpg
Views: 522
Size:  15.3 KB

    It is simply not grouping the nested column component properly.

  2. #2
    Join Date
    May 2016
    Posts
    282

    Default

    Are you completely sure both columns have the same value? If they are text columns there may be a difference of a blank space or other not printable characters.
    Regards

  3. #3
    Join Date
    Apr 2017
    Posts
    2

    Default

    Quote Originally Posted by Ana GH View Post
    Are you completely sure both columns have the same value? If they are text columns there may be a difference of a blank space or other not printable characters.
    Regards
    Yes I have checked in excel output also....they have same values.

    Another problem I am facing is: My row values has MD5 encoded(encoded in source database itself) entries, while printing in excel it is inserting blank space in between randomly.

    Please help me rectify this.

  4. #4
    Join Date
    May 2016
    Posts
    282

    Default

    I have seen that when the column width forced to split a large text in two rows (I had the cell to autoadjust vertically its size so all the text is shown). The users using copy/paste in those cells found that a return carriage or a blank space where placed where the text was splitted. Unfortunately, the only workaround was to adjust the column width, for us it isn't much a problem because only some columns are sensible to the copy/paste behaviour.
    On regard to the double column headers, I don't know what would be the problem, I haven't faced that problem.
    Regards

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.