Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Repository Explorer: Database Connections: "Unable to initialize security tab" dialog

  1. #1
    Join Date
    May 2017
    Posts
    2

    Unhappy Repository Explorer: Database Connections: "Unable to initialize security tab" dialog

    Hi there,
    I'm very new in Pentaho Data Integration (PDI) - Kettle and my issue is exactly the same as described in PDI-15871: Repository Explorer: Database Connections tab shows "Unable to initialize security tab" dialog on jira.pentaho.com site. According to this, the issue has been closed and resoluted as solved since the end of March, but I don't understand how, since there are two pending versions planned to solve this bug (October 1st and December 31st, 2017). Actions to reproduce:
    - download, install and configure the latest PDI version available (v7.0.0.0-25): all tests, according to the documentation, passed
    - fix all JDBC issues regarding needed connectors: postgresql, ms-sql and mysql: any kind of connection can be made
    - test create/save/reopen simple .ktr files with only connections inside; I've understood that only one database connection can be saved in such a file, so decide to setup a database repository for multiple connections management
    - create an empty, network accessible mysql database
    - connect to that empty database as repository (according to documentation): ok, the schema is created and tables are populated (check with MySQL Workbench)
    - open Repository Explorer > Connections and add (+) a new ms-sql database connection: no error, except nothing is displayed upon finish
    - close Repository Explorer, then reopen; click Connections Tab > "Unable to initialize Security tab"
    - try the same with a PostgreSQL empty database: exactly the same behaviour
    - check repository databases with MySQL Workbench (and PGAdmin III respectively) and new connection data are stored in R_DATABASE table, as entered
    ... still, cannot use repository for storing database connection data with "Unable to initialize Security tab" error.
    Can anyone help me ? Is there any workaround for this until new versions are released ?

  2. #2
    Join Date
    May 2017
    Posts
    2

    Unhappy Repository Explorer: Database Connections: Unable to initialize security tab

    Hi there,
    I'm very new in Pentaho Data Integration (PDI) - Kettle and my issue is exactly the same as described in PDI-15871: Repository Explorer: Database Connections tab shows "Unable to initialize security tab" dialog on jira.pentaho.com site. According to this, the issue has been closed and resoluted as solved since the end of March, but I don't understand how, since there are two pending versions planned to solve this bug (October 1st and December 31st, 2017). Actions to reproduce:
    - download, install and configure the latest PDI version available (v7.0.0.0-25): all tests, according to the documentation, passed
    - fix all JDBC issues regarding needed connectors: postgresql, ms-sql and mysql: any kind of connection can be made
    - test create/save/reopen simple .ktr files with only connections inside; I've understood that only one database connection can be saved in such a file, so decide to setup a database repository for multiple connections management
    - create an empty, network accessible mysql database
    - connect to that empty database as repository (according to documentation): ok, the schema is created and tables are populated (check with MySQL Workbench)
    - open Repository Explorer > Connections and add (+) a new ms-sql database connection: no error, except nothing is displayed upon finish
    - close Repository Explorer, then reopen; click Connections Tab > "Unable to initialize Security tab"
    - try the same with a PostgreSQL empty database: exactly the same behaviour
    - check repository databases with MySQL Workbench (and PGAdmin III respectively) and new connection data are stored in R_DATABASE table, as entered
    ... still, cannot use repository for storing database connection data with "Unable to initialize Security tab" error.
    Can anyone help me ? Is there any workaround for this until new versions are released ?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.