Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Configure SSL with Postgresql

  1. #1
    Join Date
    Apr 2014
    Posts
    18

    Post Configure SSL with Postgresql

    Hi Everyone

    I have been trying to configure SSL with Kettle on a Postgresql connection. There are many articles in the internet in relation to this, however everything points to
    change the Postgresql connection parameters. For what I am able to gather, you need to configure your JNDI connection by configuring the jdbc.properties file
    located at .../data-integeration/simple-jndi. I need to be able to set the parameter SSL=True in the connection string.

    First I thought I could set this at the kettle.properties along with the database connection, however it doesn't take the parameter.

    Have anybody able to configure this on a command line Linux installation?

    Please advice..

  2. #2
    Join Date
    Apr 2014
    Posts
    18

    Default Best Solution

    Quote Originally Posted by reynunez View Post
    Hi Everyone

    I have been trying to configure SSL with Kettle on a Postgresql connection. There are many articles in the internet in relation to this, however everything points to
    change the Postgresql connection parameters. For what I am able to gather, you need to configure your JNDI connection by configuring the jdbc.properties file
    located at .../data-integeration/simple-jndi. I need to be able to set the parameter SSL=True in the connection string.

    First I thought I could set this at the kettle.properties along with the database connection, however it doesn't take the parameter.

    Have anybody able to configure this on a command line Linux installation?

    Please advice..
    My boss was thinking completely out of the box when he proposed the following solution:
    Piggyback the configuration on another variable at the kettle.properties as follow:

    # SOURCE DATABASE
    HOST=your.database.connection.url
    PORT=5432
    DB=your_database_name?ssl=true&sslfactory=org.postgresql.ssl.NonValidatingFactory
    USER=your_user_id
    PASSWORD=your_password

    It works!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.