Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Package Installation Error

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Package Installation Error

    Hi Mark,

    I am attempting to add packages on Weka-3-9. Some of the packages install with no error, but the ones that don't all have some "zip" error thwarting installation.
    Do you an idea to get around this error?




    java.util.zip.ZipException: error in opening zip file
    at java.util.zip.ZipFile.open(Native Method)
    at java.util.zip.ZipFile.<init>(Unknown Source)
    at java.util.zip.ZipFile.<init>(Unknown Source)
    at java.util.zip.ZipFile.<init>(Unknown Source)
    at weka.core.packageManagement.DefaultPackageManager.getPackageArchiveInfo(DefaultPackageManager.java:354)
    at weka.core.packageManagement.DefaultPackageManager.installPackageFromArchive(DefaultPackageManager.java:501)
    at weka.core.packageManagement.DefaultPackageManager.installPackageFromURL(DefaultPackageManager.java:769)
    at weka.core.packageManagement.DefaultPackageManager.installPackageFromRepository(DefaultPackageManager.java:753)
    at weka.core.WekaPackageManager.installPackageFromRepository(WekaPackageManager.java:1938)
    at weka.gui.PackageManager$InstallTask.doInBackground(PackageManager.java:1308)
    at weka.gui.PackageManager$InstallTask.doInBackground(PackageManager.java:863)
    at javax.swing.SwingWorker$1.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at javax.swing.SwingWorker.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

  2. #2
    Join Date
    Aug 2006
    Posts
    1,741

    Default

    I'm afraid you'll need to upgrade to 3.9.1. Unfortunately, SourceForge changed how they serve up direct download links - sometimes they generate a redirect, and the package manager can't handle this. The issue is fixed in 3.8.1 and 3.9.1. If you upgrade, you may need to remove and re-install a number of packages. 3.8.1/3.9.1 introduce a new class loading mechanism for packages that attempts to avoid third-party library clashes between packages. This necessitated some changes to code in core and in certain packages.

    http://wiki.pentaho.com/display/DATA....8.1+and+3.9.1

    Cheers,
    Mark.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.