Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Database connection hangs

  1. #1
    Join Date
    Apr 2009
    Posts
    1

    Default Database connection hangs

    Surprised no one else has run into this (that I could find, anyhow) since it seems so basic.

    Fresh install (well, unzip) of PDI 7.0 or 7.1 (tried both) on OpenSUSE Tumbleweed. spoon.sh brings up the GUI just fine; then I try and create a Database Connection to a local Postgres instance. It configures just fine, and the "Test" button indicates success. I hit the Explore button, and... PDI is done. The "Operation in progress" popup appears, but after that it is completely unresponsive. Even kill commands have no effect until I break out the heavy hammer (-9).

    Clues:

    One core is maxed out for as long as PDI is running.

    I can see that a connection is actually made on the database side by looking at pg_stat_activity. It is just sitting there, not consuming any resources.

    I also tried just creating a "Table Input" object and running a preview; that resulted in the same hang behavior.

    If I click on "Feature List" when I configure the connection, something odd: at the top it says "Feature list (49 rows)" but there is only 1 empty row.

    No difference in behavior is seen whether I use the wizard or just fill in the values from "New".

    No log output occurs as a result of this problem

    Java version is the OpenJDK 8.

    Thanks for any help!

  2. #2
    Join Date
    May 2016
    Posts
    280

    Default

    For what is worth, it happens the same to me in an Pentaho 6.1 with the Oracle DB connection I have defined, it works with a MySQL DB connection. Ignore it, the connection will work, you just won't be able to use the help to find the table you want to query in steps like the Table Input, but if you write the query it will work, and columns in the table in steps like Table Output get populated.
    Regards
    OS: Ubuntu 16.04 64 bits
    Java: Openjdk 1.8.0_131
    Pentaho 6.1 CE

  3. #3

    Default Database Hangs

    Quote Originally Posted by Ana GH View Post
    For what is worth, it happens the same to me in an Pentaho 6.1 with the Oracle DB connection I have defined, it works with a MySQL DB connection. Ignore it, the connection will work, you just won't be able to use the help to find the table you want to query in steps like the Table Input, but if you write the query it will work, and columns in the table in steps like Table Output get populated.
    Regards


    Have you got any resolution for the above problem. Even I am facing the same issue. Using pentaho 6 and when I connect to oracle alone it hangs, working very much fine with mysql.
    Regards,
    Dileep
    Mail ID

  4. #4
    Join Date
    May 2016
    Posts
    280

    Default

    Quote Originally Posted by saidlp13 View Post
    Have you got any resolution for the above problem. Even I am facing the same issue. Using pentaho 6 and when I connect to oracle alone it hangs, working very much fine with mysql.
    There's no problem connecting to OracleDb, the problem is trying to retrieve the list of tables as a help. As I don't have problems using SQL Developer or Toad, I just build the query there and copy it in Table Input part. Do you have problems with the connection or it is just with the help to retrieve available tables?
    OS: Ubuntu 16.04 64 bits
    Java: Openjdk 1.8.0_131
    Pentaho 6.1 CE

  5. #5

    Default

    Retrieve available tables is the problem.
    Regards,
    Dileep
    Mail ID

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.