Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Error - Mondrian looking to wrong aggregation

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Apr 2013
    Posts
    24

    Exclamation Error - Mondrian looking to wrong aggregation

    Hello everyone!

    We have strange error with Pentaho 7.0.

    It seems like in some cases Mondrian tries to get some db field from aggregation, which, in fact, have no such field in schema.
    Of course, it leads to error:

    Table:
    name=tbaTicket_YM
    relation=public.tbaTicket_YM
    numberofrows=41
    FactCount:
    Fact Count (-1): "tbaTicket_YM"."FactCount"
    Measures:
    [TaxAmtSubAgent] (156): sum("tbaTicket_YM"."TaxAmtSubAgent")
    [CouponCount] (153): sum("tbaTicket_YM"."CouponCount")
    [ComissionAmt] (159): sum("tbaTicket_YM"."ComissionAmt")
    [Count BSO] (151): sum("tbaTicket_YM"."TicketCount")
    [PenaltyAmt] (158): sum("tbaTicket_YM"."PenaltyAmt")
    [ClaimCount] (165): sum("tbaTicket_YM"."ClaimCount")
    [OperationDurationAvg] (163): sum("tbaTicket_YM"."OperationDurationAvg" * "tbaTicket_YM"."FactCount") / sum("tbaTicket_
    YM"."FactCount")
    [TaxAmtAgent] (155): sum("tbaTicket_YM"."TaxAmtAgent")
    [FareAmt] (152): sum("tbaTicket_YM"."FareAmt")
    [OperationDurationSum] (164): sum("tbaTicket_YM"."OperationDurationSum")
    [TaxAmt] (154): sum("tbaTicket_YM"."TaxAmt")
    [VoidDuration] (167): sum("tbaTicket_YM"."VoidDuration")
    [OperationCount] (160): sum("tbaTicket_YM"."OperationCount")
    [TicketingDuration] (166): sum("tbaTicket_YM"."TicketingDuration")
    [TaxBSOAmt] (157): sum("tbaTicket_YM"."TaxBSOAmt")
    [IsDataValid] (161): min("tbaTicket_YM"."IsDataValid")
    Levels:
    Month (16): "tbaTicket_YM"."Month"
    Year (13): "tbaTicket_YM"."Year"
    has no column for AirlineAllianceName (1): "qryAirline"."AirlineAllianceName" (bitPos 1)
    at java.util.concurrent.FutureTask.report(FutureTask.java:122)
    at java.util.concurrent.FutureTask.get(FutureTask.java:206)
    at com.pentaho.analyzer.report.ReportRequestService.get(SourceFile:175)

    Why is it so? Is it a bug, or we're doing something wrong?

    PS: logs attached
    Attached Files Attached Files

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.