Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: Kettle file works fine in PDI but columns don't show up in PRD

  1. #1

    Default Kettle file works fine in PDI but columns don't show up in PRD

    I am using PDI and PRD version 6.1
    My connection type is either MySQL or Redshift JDBC.

    The kettle file works fine in PDI and I can preview data.
    The kettle file has parameters
    I imported the kettle file in PRD and I can preview data. But columns just don't show up so I can design my report.

    Can someone help out?

  2. #2
    Join Date
    Aug 2016


    I thought that was normal for PDI datasource? Always has been like that for me

    Run the preview and screenshot it for the column names. Add your relevant fields to the report (number, date, label etc) and then manually type the names into the field value under attributes

    It will work when you run it then. Bit of a pain though if you have loads of columns

  3. #3


    Hi Deanicus,
    I tried your approach but it didn't work
    This kind of issue only happens when I have parameters/variables in the kettle file

  4. #4
    Join Date
    Aug 2016


    Hmmm. That's odd

    I just looked at a report I created with a variable and like you, the columns don't show if I click select query but if I type them in, it does work. I just tested by manually changing one of the fields to another one

    Perhaps double check your variables? If you set a default within the PDI file then the preview within PRD uses that. However at runtime if your variables are not passing correctly, then it will be blank (Edit: just tested this and it went back to the default so I don't think that is it. I also built a report without the wizard and the manual typing worked there too)

    Another attempt to consider, I normally start a report using the wizard and direct query the DB (I use NULL values for things I will be adding with PDI). I then set up the report with this direct query. Later I create my PDI file and change the data source to the PDI. Since the same query is powering both of them (remove the NULL fields for the PDI one) the field names will be the same and 99% of the time it will work first time.

    Perhaps that is the difference?
    Last edited by Deanicus; 07-24-2017 at 07:00 AM.

  5. #5
    Join Date
    Aug 2016


    Here is a quick snip of my tester file and the attributes tab for a number_field

    I literally just typed customer_id here and it worked fine despite no fields showing on the Data tab

    Name:  PDI.jpg
Views: 400
Size:  23.4 KB

  6. #6
    Join Date
    Aug 2006


    Can you end the KTR with a dummy step and use that for the PRD Query?

  7. #7


    Yes, I have the dummy step and use that for PRD Query.

    I also created a ticket to Pentaho. They asked me to try this approach:

    But it also doesn't work out.

    If I use "Get variables" step and then my parameter = ? (e.g: pub_id = ? in where condition) then it works (columns do show up). But this approach is only for 1 parameter and in Where condition. Now, for this specific transformation, I need to use more than 1 parameters, and not only in Where condition, but also in column name. Kettle file works fine, but columns just don't show up in PRD.

    I just can't figure out how to make columns shown.
    Last edited by tleimprovedigital; 07-27-2017 at 05:24 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.