Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: The table component does not refresh the data

  1. #1

    Default The table component does not refresh the data

    Hy guys, it is my first thread in the forum.

    I can't make the table refresh the data based on the filter settings this way:

    Attachment 18451

    The param receipt the value that filter the selection correctly on MDX query, but when I link the param to the select
    who has the values for the filter, it does no filter the data for the table, the settings for the select follows:

    Attachment 18452

    And the datasource over mondrian that should receive the value parameter on the query:

    Name:  datasource_top_produtos.jpg
Views: 347
Size:  12.6 KB

    And the MDX query:

    Name:  query_mdx_produtos_empresa.jpg
Views: 300
Size:  13.0 KB

    I need to know what I doing wrong or what I need to do for make the filter data refresh selecting the option on the select.

    thanks in advance

  2. #2
    Join Date
    Nov 2011
    Posts
    1,229

    Default

    Your attachments are not showing up. But a couple of questions:

    1. When you say it does not filter, do you mean you get the same rows or no rows at all?
    2. Have you checked the server logs for query execution errors?
    3. is param_empresa_produto a valid dimension member name?
    Pedro Vale
    --
    CTools Product Development
    http://www.webdetails.pt

  3. #3

    Default

    Now I'm far from my home, I'll detail better when I be there, so the questions:

    1- I get the same rows like it was defined in MDX query on datasource, but the MDX query get the value of the parameter I created
    2- I did many times
    3- If me understand your question, param_empresa_produto is just the name of the simple parameter who holds the value of the select os the companies


  4. #4
    Join Date
    Jul 2017
    Posts
    8

    Default

    Have you set listener of that parameter on table? So it will always change after parameter change? I don't see a single mention about this, so I think that could be your solution

    To change it go to table properties and in Listener (maybe Listening, I'm not sure) property select your parameter.
    Last edited by SomPanko; 08-08-2017 at 04:18 AM.

  5. #5

    Default

    Ok guys, sorry about the delay returning to the thread.
    I trying to send the image of select component

    Name:  select componente.jpg
Views: 295
Size:  11.2 KB

    Now the image about the parameter:

    Name:  param_empresa_produto.jpg
Views: 290
Size:  10.7 KB

    And the parameter, you realize that the listener is on the property

    Name:  table_produtos.jpg
Views: 290
Size:  12.1 KB

  6. #6
    Join Date
    Jul 2017
    Posts
    8

    Default

    In select component you have in property Parameter lista_empresasParameter, but there should be your param_empresa_produto because this property of select component means into which Parameter new value will be assigned. So param_empresa_produto never changes because of that and listening it in table component does nothing

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.