Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Mondrian Virtual Cube - not working

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Mondrian Virtual Cube - not working

    Hello All

    i have a problem with implementing virtual cubes in Mondrian
    here is the virtual cube i build as a prototype:

    Code:
    <Schema name="VIRTUALCUBE">
        <Cube name="CARS" visible="true" cache="true" enabled="true">
            <Table name="CARS">
            </Table>
            <Dimension visible="true" foreignKey="ID" highCardinality="false" name="CARS INFO">
                <Hierarchy name="TYPE" visible="true" hasAll="true" primaryKey="ID">
                    <Table name="CARS">
                    </Table>
                    <Level name="TYPE" visible="true" column="TYPE" type="String" uniqueMembers="false" levelType="Regular" hideMemberIf="Never">
                    </Level>
                </Hierarchy>
            </Dimension>
            <Measure name="COUNT" column="COUNT" formatString="#" aggregator="sum">
            </Measure>
        </Cube>
        <Cube name="CUSTOMER" visible="true" cache="true" enabled="true">
            <Table name="CUSTOMER">
            </Table>
            <Dimension visible="true" foreignKey="ID" highCardinality="false" name="CUSTOMER">
                <Hierarchy name="NAME" visible="true" hasAll="true" primaryKey="ID">
                    <Table name="CUSTOMER">
                    </Table>
                    <Level name="NAME" visible="true" column="NAME" type="String" uniqueMembers="false" levelType="Regular" hideMemberIf="Never">
                    </Level>
                </Hierarchy>
            </Dimension>
            <Measure name="CUSTOMERCOUNT" column="CUSTOMERCOUNT" formatString="#" aggregator="sum">
            </Measure>
        </Cube>
        <VirtualCube enabled="true" name="VIRTUAL CUSTOMER CARS" visible="true">
            <VirtualCubeDimension cubeName="CARS" visible="true" foreignKey="ID" highCardinality="false" name="CARS INFO"></VirtualCubeDimension>
            <VirtualCubeDimension cubeName="CUSTOMER" visible="true" foreignKey="ID" highCardinality="false" name="CUSTOMER"></VirtualCubeDimension>
            <VirtualCubeMeasure cubeName="CARS" name="[Measures].[COUNT]" visible="true"></VirtualCubeMeasure>
            <VirtualCubeMeasure cubeName="CUSTOMER" name="[Measures].[CUSTOMERCOUNT]" visible="true"></VirtualCubeMeasure>
        </VirtualCube>
    </Schema>
    when i use each cube's dimension with its own measure, it works. but when i try to select both dimensions from both cubes with the measures, Mondrian is showing no Data?
    what is wrong where?
    the to fact tables have the relationship "1 to n" ... is there any why to tell Mondrian that? or to connect both fact tables?

    any advice is more than welcome, please
    thanks
    Last edited by PenBI; 08-18-2017 at 11:37 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.