Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Spoon cannot explore SYBASE- Error getting views from schema [null]

  1. #1
    Join Date
    Sep 2017
    Posts
    1

    Default Spoon cannot explore SYBASE- Error getting views from schema [null]

    I am able connect with Pentaho Data Integration version 7.1 to a Sybase database using Native (JDBC). I have placed the file jtds-1.3.1.jar in the lib folder of the pentho installation to make it work on my Windows 10 Computer.

    I can Query fields with the table Input-step of type Integer but if I choose anothe datatype or try to explore database I get an error message: Error getting views from schema [null]

    I have worked with Kettle using Oracle many years, but my understanding of Sybase is limited.

    Can anyone give a clue?

    Do I need to Place other files in the lib folder?

    I also get error-message when I try to use ODBCriver class 'sun.jdbc.odbc.JdbcOdbcDriver' could not be found, make sure the 'Sybase' driver (jar file) is installed.

    I need very simple and Concrete instructions, please.

    /Marcus
    Attached Images Attached Images  
    Last edited by steenmar; 10-01-2017 at 03:49 PM.

  2. #2
    Join Date
    Jun 2017
    Posts
    3

    Default

    Same problem here... Have you found a solution?

  3. #3
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Always post the versions of everything that you're using.

    If you're using Sybase 7 the answers can easily be different than if you're using Sybase 15.


    OS .(Type & Version):
    PDI.(Type & Version):
    DB .(Type & Version):
    Java(Type& Version):

  4. #4
    Join Date
    Jun 2017
    Posts
    3

    Default

    Sorry, the details are,

    OS Windows Server 2012 R2
    PDI 5.0.1 stable
    DB Sybase Anywhere 12
    Java 8 upd 131

    I can setup the connection using Native (JDBC) but I can't get sql statements.
    I have also placed jtds-1.3.1.jar in lib folder.

    Thanks

  5. #5
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Based on other threads that I found from a quick search, looks like there's perhaps a bug in the dialect definition.
    If you can run your table input without doing an explore, then file a bug a http://jira.pentaho.com

  6. #6
    Join Date
    Jun 2017
    Posts
    3

    Default

    Thanks for your fast reply!
    I have opened the case PDI-16759

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.