Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Setting Mail with Gmail

  1. #1
    Join Date
    Oct 2016
    Posts
    2

    Default Setting Mail with Gmail

    I tried to set up mail job in KETTLE.

    I use following setting from following thread.
    http://forums.pentaho.com/showthread...il-using-Gmail

    SMTP Server: smtp.gmail.com
    Port: 465
    Authentication: check
    Authentication User: youraccount@gmail.com
    Authentication Password: *******
    Use Secure Authentication: checked
    Secure Connection Type: SSL
    However, I got following error

    2016/10/23 21:33:23 - Mail - ERROR (version 6.1.0.1-196, build 1 from 2016-04-07 12.08.49 by buildguy) : Problem while sending message: javax.mail.MessagingException: Could not connect to SMTP host: smtp.gmail.com, port: 465; nested exception is:
    javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
    2016/10/23 21:33:23 - Email - Finished job entry [Mail] (result=[false])
    I did google around and found this thread.
    http://forums.pentaho.com/showthread...ification-path

    So I get cert by using openssl (http://notepad2.blogspot.com/2012/04...into-java.html)

    s_client -connect smtp.gmail.com:465

    and tried add cert to keystore using keytool command as this link
    http://www.joyofdata.de/blog/suncert...in-pdi-kettle/

    keytool -import -alias smtp.gmail.com -keystore "%JAVA_HOME%/jre/lib/security/cacerts" -file C:\Users\wilson\gmail.cert
    However, I still got error. I have no idea where to fix next. Please help.
    Last edited by tanakornp; 10-23-2016 at 11:07 AM.

  2. #2
    Join Date
    Oct 2016
    Posts
    2

    Default

    I solved this problem and I wanna post it here just in case anyone got the same problem.

    Problem I have caused by AVAST antivirus.

    You'll need to turn off HTTPS protection and SMTP scanning.

    Furthermore you'll need gmail to allow less secure app. (https://www.google.com/settings/security/lesssecureapps)

  3. #3
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    Quote Originally Posted by tanakornp View Post
    I solved this problem and I wanna post it here just in case anyone got the same problem.
    Thank you very much for coming back to post your solution.
    Sadly, not everybody does so.
    So long, and thanks for all the fish.

  4. #4
    Join Date
    Jun 2007
    Posts
    103

    Default

    A year later - I thank you also for posting the solution. Avast was recently installed (we used AVG before) and I would not have guessed.

    - Russell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.