We have recently upgraded the version of the JDBC driver that is being used to allow Kettle to write to our FileMaker databases. In a previous version of the driver, from 2013, both Insert/Update and Update worked properly.

In an older version of the driver, the Update and Insert/Update steps worked just fine. In the new version of the driver, Updates fail with the following error:

[FileMaker][FileMaker JDBC] Cursor has been closed.

Based on FileMaker's documentation, this might be being caused by the exclusion of a feature of JDBC 3.0:

About the JDBC client driver
The JDBC client driver provides partial support for the JDBC 3.0 specification. The following features are not supported by FileMaker:
- holdable cursors

My questions for the forum:

1. how does Kettle involve cursors in its update process? Is it using a "holdable cursor" and therefore running afoul of the newer plugin? Or is a "holdable cursor" part of the JDBC 3.0 spec and not necessary for a successful update?
2. What direction do we need to give to FileMaker so that they can most efficiently update the JDBC Driver so it works properly? Is this a missing feature for them, or likely to be a bug in the driver? Is there a log level that might expose it as a bug?

Thanks in advance.