Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Full outer join on string key

  1. #1

    Default Full outer join on string key

    Name:  Capture.jpg
Views: 121
Size:  12.7 KB

    Hi all, I am trying to make full outer join on those key where the keys are strings. It doesn't work well.

    If I do the same thing with the numbers, I get valid results.

    An inner join is not an option because I need to see what has matched and what didn't.

    Any idea?

    Thanks.

  2. #2
    Join Date
    May 2016
    Posts
    282

    Default

    You'll have to provide more details to get help. Why doesn't it work well? Are you not getting the expected output? Does it throw an error? Is the transformation executing without ending?
    OS: Ubuntu 16.04 64 bits
    Java: Openjdk 1.8.0_131
    Pentaho 6.1 CE

  3. #3

    Default

    I am getting the output, no official error reported.

    If I have the case where country_c = "Italy" and Name_Common ="Italy" they still mismatch providing the following output:

    Id country_client alter_id Name_Common
    1 Italy
    2 Germany
    3 England
    178 Italy
    179 Germany
    180 England

  4. #4
    Join Date
    Sep 2011
    Posts
    152

    Default

    have you tried Merge Join step with Full Outer join , i check with Merge join and got correct result.

  5. #5
    Join Date
    Nov 2013
    Posts
    382

    Default

    Check for trailing spaces. Check you are using the same encoding on both data flows.

  6. #6

    Default

    I tried that as well and activated trims. Still no luck. Any other idea please?

  7. #7

    Default

    I am using the trim option so that should take care of the spaces. You were right about the encoding. It's different (UTF-16 and UTF-8). How can I overcome that?
    I can't change the data, it is what it is unfortunately.

  8. #8
    Join Date
    May 2014
    Posts
    358

    Default

    I haven't used the Multiway merge join, but with Merge join and string keys, ordering is important. Pentaho expects binary collation.

  9. #9
    Join Date
    Nov 2013
    Posts
    382

    Default

    Quote Originally Posted by marijamilojevic87@yahoo.c View Post
    I am using the trim option so that should take care of the spaces. You were right about the encoding. It's different (UTF-16 and UTF-8). How can I overcome that?
    I can't change the data, it is what it is unfortunately.
    Select Step >> Metadata >> Encoding

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.