Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Plugin Saiku 3.8.8 doesn't load on Pentaho 6.1

  1. #1
    Join Date
    Oct 2017
    Posts
    1

    Default Plugin Saiku 3.8.8 doesn't load on Pentaho 6.1

    Hello,

    Some time a go I installed a working copy of Pentaho 6.1.0.1.196 with plugin Saiku 3.8.8(PENTAHO6), both were completely functional.
    Recently I've notice that Saiku Analytics doesn't load. Message "loading..." is showed without load anything.

    After search over the web I don't found anything to fix it. I've tried several options before write here, as:
    • Reinstall Saiku across the market place. This doesn't work because install or delete return the follow: "Do you want to uninstall? Error occurred when uninstalling plugin Saiku Analytics.[ Failed to execute uninstall, see log for details.]" I don't know wich log have to see in :S
    • Reinstall Saiku plugin throught the zip file. This doesnt work and option write in the log something like: "pentaho plugin manager PluginManager.ERROR_0024 - A plugin has already been registered by name saiku."
    • Change the licence file
    • Delete the Analysis imported and created it again. This doesn't work.


    In catalina.out logfile it showing the follow, but I have a working local copy and show the same:

    16:30:06,916 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/saiku/plugins/CCC_Chart/cdo.js not found in plugin saiku
    16:30:07,730 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/saiku/plugins/CCC_Chart/cdo.js not found in plugin saiku
    16:33:01,387 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/backbone/underscore-min.map not found in plugin saiku
    16:33:17,349 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/saiku/plugins/CCC_Chart/cdo.js not found in plugin saiku
    16:33:17,970 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/backbone/underscore-min.map not found in plugin saiku
    16:33:18,210 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/saiku/plugins/CCC_Chart/cdo.js not found in plugin saiku
    16:41:30,046 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/saiku/plugins/CCC_Chart/cdo.js not found in plugin saiku
    16:41:30,809 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/saiku/plugins/CCC_Chart/cdo.js not found in plugin saiku
    16:41:46,573 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/saiku/plugins/CCC_Chart/cdo.js not found in plugin saiku
    16:41:47,166 ERROR [GenericServlet] GenericServlet.ERROR_0004 - Resource /saiku-ui/js/saiku/plugins/CCC_Chart/cdo.js not found in plugin saiku

    At last, the log showed on de browser is the follow:
    Name:  logSaiku.jpg
Views: 561
Size:  13.0 KB

    At this point I dont find a solution apart of reinstall the whole Pentaho BI server, but I would like avoid it.
    Anybody have a clue what it's happend here?

    Thanks in advance

  2. #2
    Join Date
    Oct 2016
    Posts
    1

    Default

    My pentaho version is 7.1 CE, I was met this issue. Maybe you can follow my steps:
    Firstly, I deleted saiku plugin manually.
    1. delete all saiku folders and files as follow:
    ~pentaho-solutions/system/saiku
    ~pentaho-solutions/system/plugin-cache/backups/saiku*
    2. delete the files under /pentaho/pentaho-server/tomcat/work/Catalina/ folder
    3. restart pentaho server.
    After that, the saiku plugin cannot found in web.
    Secondly, download the right the saiku plugin version and put the zip to ~/pentaho-server/pentaho-solutions/system/ folder, then unzip it and copy your license to the saiku folder after you unzip it.
    Thirdly, the key to solve Message always "loading..." , please follow this tips:
    http://jira.pentaho.com/browse/BISERVER-13666

    Replacing the related .jar files in ../system/saiku/lib with the following (wich one could take from ../system/sparkl/lib)
    will fix the problem:

    cpf-core-7.1.0.0-12.jar
    cpf-pentaho-7.1.0.0-12.jar
    cpk-core-7.1.0.0-12.jar
    cpk-pentaho5-7.1.0.0-12.jar

    Since I used pentaho 7.1 CE, so it works after I followed above steps. You can replace these files from ../system/sparkl/lib in your server.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.