Hello,
I am trying PostgreSQL 10.0 since it has some great features (like native partitioning).

The question is: Pentaho suite CE supports latest JDBC (42.1.4) drivers which they supports PostgreSQL 10.0?

I am asking this because on the wiki page it's written an old version of JDBC driver.