I am currently using Pentaho Data Integration 7.1 for a certain app which requires the usage of a third party application. I've already added a jar in the libext folder and made the appropriate changes in the in the launcher.properties. However the third party application uses jersey-client:2.8 and I saw that Pentaho uses jersey-client 1.19 in it's lib folder. While using the third part app in the UDJC I end up getting an error ( java.lang.NoSuchMethodError: javax.ws.rs.core.MultivaluedMap.addAll(Ljava/lang/Object;[Ljava/lang/ObjectV ) which I believe is due to this incompatibility. Is there any way to override the jersey-client 1.9 used in Pentaho given that it's an older version when it was a part of the com.jersey.sun, now its a part of org.glassfish.jersey ?