Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Report based on transformation with JSON input

  1. #1
    Join Date
    Sep 2014
    Posts
    8

    Default Report based on transformation with JSON input

    Hi,
    I have a transformation which does run just fine on PDI and BI server (as datasource).
    When trying to use the transformation as a datasource inside Report Designer I get the following error:

    Code:
    2017-10-23 11:35:50,205 [1155500]  ERROR - org.pentaho.reporting.engine.classic.core.modules.gui.commonswing.ExceptionDialog - ExceptionDialog.ERROR_0001 – UserErrororg.pentaho.reporting.engine.classic.core.ReportDataFactoryException: Caught Kettle Exception: Check your configuration
        at org.pentaho.reporting.engine.classic.extensions.datasources.kettle.KettleDataFactory.queryData(KettleDataFactory.java:100)
        at org.pentaho.reporting.ui.datasources.kettle.KettleDataSourceDialog$KettlePreviewWorker.run(KettleDataSourceDialog.java:485)
        at java.lang.Thread.run(Thread.java:745)
    Caused by: org.pentaho.di.core.exception.KettleException: 
    We failed to initialize at least one step.  Execution can not begin!
    
        at org.pentaho.di.trans.Trans.prepareExecution(Trans.java:1157)
        at org.pentaho.reporting.engine.classic.extensions.datasources.kettle.AbstractKettleTransformationProducer.prepareTransformation(AbstractKettleTransformationProducer.java:284)
        at org.pentaho.reporting.engine.classic.extensions.datasources.kettle.AbstractKettleTransformationProducer.performQueryOnTransformation(AbstractKettleTransformationProducer.java:248)
        at org.pentaho.reporting.engine.classic.extensions.datasources.kettle.AbstractKettleTransformationProducer.performQuery(AbstractKettleTransformationProducer.java:231)
        at org.pentaho.reporting.engine.classic.extensions.datasources.kettle.KettleDataFactory.queryData(KettleDataFactory.java:96)
    ... 2 more
    While removing steps in the transformation for debugging purpose, I noticed this happens when running Json input right after REST client. PDI datasources without Json Input seem to work fine...
    Since my datasource is JSON RPC I need to read the data from the response using path expressions.

    OS: Mac OS X 10.12
    Pentaho: 7.1.0.0-12

    Anyone ideas how to solve this issue?

    Name:  DAL_File_preview.jpg
Views: 276
Size:  27.0 KB
    DAL_Files_list_debug.ktr.zip

  2. #2
    Join Date
    Sep 2014
    Posts
    8

    Default

    PS: I had the chance to check on Windows - it works! So this seems to be related to the platform (Linux/OS X)...

  3. #3
    Join Date
    Oct 2017
    Posts
    3

    Default

    I tried the same with an older version of the reporting tool (7.0.0.0-25).
    This does not have this issue.

    So it's a bug in the latest version PRD 7.1.0.0-12.
    Last edited by rikkie; 10-30-2017 at 05:59 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.