Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Error after migrate to 7.1 (BlueprintContainerImpl)

  1. #1
    Join Date
    Sep 2014
    Posts
    5

    Default Error after migrate to 7.1 (BlueprintContainerImpl)

    Hello

    I have a problem that I can't solve. I migrated from Kettle 5.4 running on 1.7 Java to Kettle 7.1 running on 1.8. I have a mysql ETL repository and I use the Windows Scheduler to program the proccess.

    Sometimes (and I don't know why), the Java proccess freezes and it can't be executed again. All I can see in the log is:

    ERROR [BlueprintContainerImpl] Unable to start blueprint container for bundle org.apache.karaf.shell.console
    org.osgi.service.blueprint.container.ComponentDefinitionException: Unable to initialize bean secureCommandConfigTransformer

    What's the problem? How can solve it?

    Thanks a lot.

  2. #2
    Join Date
    Sep 2014
    Posts
    5

    Default

    I add more info:

    06:20:20,102 ERROR [BlueprintContainerImpl] Unable to start blueprint container for bundle org.apache.karaf.shell.console
    org.osgi.service.blueprint.container.ComponentDefinitionException: Unable to initialize bean secureCommandConfigTransformer
    at org.apache.aries.blueprint.container.BeanRecipe.runBeanProcInit(BeanRecipe.java:714)
    at org.apache.aries.blueprint.container.BeanRecipe.internalCreate2(BeanRecipe.java:824)
    at org.apache.aries.blueprint.container.BeanRecipe.internalCreate(BeanRecipe.java:787)
    at org.apache.aries.blueprint.di.AbstractRecipe$1.call(AbstractRecipe.java:79)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:88)
    at org.apache.aries.blueprint.container.BlueprintRepository.createInstances(BlueprintRepository.java:245)
    at org.apache.aries.blueprint.container.BlueprintRepository.createAll(BlueprintRepository.java:183)
    at org.apache.aries.blueprint.container.BlueprintContainerImpl.instantiateEagerComponents(BlueprintContainerImpl.java:682)
    at org.apache.aries.blueprint.container.BlueprintContainerImpl.doRun(BlueprintContainerImpl.java:377)
    at org.apache.aries.blueprint.container.BlueprintContainerImpl.run(BlueprintContainerImpl.java:269)
    at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:294)
    at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:263)
    at org.apache.aries.blueprint.container.BlueprintExtender.modifiedBundle(BlueprintExtender.java:253)
    at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:500)
    at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:433)
    at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$AbstractTracked.track(BundleHookBundleTracker.java:725)
    at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.bundleChanged(BundleHookBundleTracker.java:463)
    at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$BundleEventHook.event(BundleHookBundleTracker.java:422)
    at org.apache.felix.framework.util.SecureAction.invokeBundleEventHook(SecureAction.java:1127)
    at org.apache.felix.framework.util.EventDispatcher.createWhitelistFromHooks(EventDispatcher.java:696)
    at org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:484)
    at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4429)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:2100)
    at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
    at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
    at java.lang.Thread.run(Thread.java:748)
    Caused by: java.io.IOException: Unexpected token 78; expected: 61 (line=0, pos=202)

  3. #3
    Join Date
    Sep 2014
    Posts
    5

    Default

    Is there no one with the same problem? Thanks!

  4. #4
    Join Date
    Jul 2015
    Posts
    2

    Default

    Yes, I am having the same problem. Does anyone know the solution to this error?
    I would appreciate an answer. Thank you very much.

  5. #5
    Join Date
    Sep 2014
    Posts
    5

    Default

    up!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.