Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Can see repos drop down or open connect to repo dialog at start up

  1. #1
    Join Date
    Oct 2017

    Default Can see repos drop down or open connect to repo dialog at start up

    Hi there, forgive me please if this is answered elsewhere. I have not found an answer that works for me yet. I have installed a few times and tried a few different versions and methods. I am on MacOS Sierra 10.12.6 (16G29) and have tried to install from
    I install to /Applications/. The mac is a new refurb that i am setting up for work. Java version 9.0.1 (build 9.0.1+11) x86_64

    I have ~/.kettle/repositories.xml in place and pointing to existing repos

    And then I run the blessings I have seen in another post:
    sudo xattr -dr /Applications/data-integration/Data\

    Then I can click the Data icon and it will bounce in the dock for an extended time before the application shows. Then when it does there is no Connect Repos option under tools. The new right hand side Connect drop down does not appear and even though enabled the connect repositories dialog didn't open during start up. I have googled myself senseless and need help.

    Other posts' solutions I have tried include starting from the cli. This results in the Data icon appearing in the doc but no application window available for use and a score of errors from

    I'll paste the beginning of those here and attach the full log in attachments.

    Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0
    WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.pentaho.di.core.plugins.KettleURLClassLoader (file:/Applications/data-integration/launcher/../lib/kettle-core- to field
    WARNING: Please consider reporting this to the maintainers of org.pentaho.di.core.plugins.KettleURLClassLoader
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release
    18:00:07,741 INFO [KarafBoot] Checking to see if org.pentaho.clean.karaf.cache is enabled
    18:00:07,826 INFO [KarafInstance]
    *** Karaf Instance Number: 1 at /Applications/data-integration/./system/kar ***
    *** af/caches/spoon/data-1 ***
    *** Karaf Port:8802 ***
    *** OSGI Service Port:9051 ***

    Any assistance is appreciated.

    I'm hoping it's something obvious and obnoxious like wrong java version or something else simply missing from a new bare box.
    Attached Files Attached Files

  2. #2
    Join Date
    Oct 2017


    Well the answer was the Java version. I couldn't get the pdi ce to run on Sierra or High Sierra with Java 9. I couldn't get it running with Java jdk-8u152-macosx-x64.dmg ... although that may have been trouble from uninstalling 9. But with jdk-8u151-macosx-x64.dmg and I was able to get the repository Connect drop down back. Hope this may save some other goofy soul some time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.