Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: REST Client HTTPS fail when run via Kitchen, but not through Spoon

  1. #1
    Join Date
    Nov 2017

    Angry REST Client HTTPS fail when run via Kitchen, but not through Spoon

    Using Pentaho PDI v6.0.1.0-386.

    So i have a transformation where Im passing the GET method from a URL (SharePoint) to a REST Client to pull a XML file. Recently we shifted from HTTP to HTTPS and ive updated the java keystores to include the certificates necessary for HTTPS authentication.

    The issue arises when i run the Job via Kitchen. When i run it via Spoon GUI, I don't have any issues. The transformation piece fails at the REST client portion when running via Kitchen batch job.

    I've included the trust store path in Java Options


    2017/10/24 14:02:59 - Table input.0 - Finished processing (I=7094, O=0, R=0, W=7094, U=0, E=0)
    2017/10/24 14:03:00 - REST Client.0 - Connecting to [https://***REDACTED***] ...
    2017/10/24 14:03:00 - [REDACTED].dwhse - Statement canceled!
    2017/10/24 14:03:00 - [REDACTED].dwhse - Statement canceled!
    2017/10/24 14:03:00 - REST Client.0 - Signaling 'output done' to 2 output rowsets.
    2017/10/24 14:03:00 - REST Client.0 - Finished processing (I=0, O=0, R=1, W=0, U=0, E=1)
    2017/10/24 14:03:00 - ReadXMLFiles - Transformation detected one or more steps with errors.
    2017/10/24 14:03:00 - ReadXMLFiles - Transformation is killing the other steps!

    Im not sure what the root cause of this issue could be or where to start debugging this issue.

    Ill gladly provide any details to help resolve this issue.

  2. #2
    Join Date
    Jun 2012


    The first thing I would do is to build the smallest POC to analyze the problem.
    That would be a REST-Client fed by a single row of constants.
    And you should change the Kettle log level to Debug or RowLevel while you're at it.
    SSL debugging might help, too:
    So long, and thanks for all the fish.

  3. #3
    Join Date
    Nov 2017


    Thanks for the tip marabu! SSL debug helped! The debug log showed that it wasnt finding a truststore. I was point it to the keystore with the certs. Upon further researching, I moved my newly created truststore file over the root of the pdi folder. Edited my java options accordingly (see below).


    Re-ran the job using the kitchen. The debug log found the new truststore file and REST Client is properly authenticating the HTTPS request.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.