Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Invisible-consumes-space - simple example not working

  1. #1
    Join Date
    Nov 2017
    Posts
    8

    Default Invisible-consumes-space - simple example not working

    Hello,

    Just to test the "invisible-consumes-space" flag, I created this simple report.
    I do this query:

    select NULL as X, 2 as Y from dual

    Using a simple form with 2 labels and 2 string-fields.

    Following the instructions I met, I set layout=row and invisible-consumes-space = false.
    I could use some formula "=NOT(ISBLANK(X))" for visible; but I just set visible = false for string-field X so it should never be shown.

    I expected that X would not be shown and Y would be moved to the left.
    In fact, that happens at design time (see figure 1.jpg).
    But this doesn´t happen at runtime (see figure2.jpg).
    So, what´s missing ? I attach my report (Spaces2.ppt).

    Thanks in advance,
    Emerson
    Attached Images Attached Images   
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2017
    Posts
    8

    Default

    I´m using version 3.8.0.

    Can anybody please give me a light ?
    Did anyone try to run my report ? Are the results the same ?
    This seems so simple, but where´s the error ?

    Thanks.

  3. #3
    Join Date
    Aug 2016
    Posts
    142

    Default

    Try setting it to false on the details band itself

  4. #4
    Join Date
    Nov 2017
    Posts
    8

    Default

    Deanicus,

    On this Spaces2.prprt attached, I´ve already set invisible-consumes-space to false for Details band,but this is not working.
    I did some experiences setting this option to false in each band (Details, Details Body, Group, Master Report) and it still doesn´t work.

  5. #5
    Join Date
    Aug 2016
    Posts
    142

    Default

    Hmm

    Very strange.

    I had to make a couple of changes to the PRPT for it to run but when I did, the X field disappears as expected

    See attached
    Attached Files Attached Files

  6. #6
    Join Date
    Nov 2017
    Posts
    8

    Default

    Deanicus,

    Which Pentaho version are you using ? With 3.8.0 my results with your .prpt were same as before.
    The X field disappears, but its space is not shifted to the left.

    (I had to change field names x and y to X and Y - this version seems not to work well with lowercases.)

  7. #7
    Join Date
    Nov 2017
    Posts
    8

    Default

    But later ... I looked for some hint in YouTube tutorials, then tried to insert a band in my report, and did experiences changing the layouts (from Details band and from this new band) to row or block or canvas.

    I´m not so sure, but these are these conclusions I reached:

    When layout = block: text-fields are positioned vertically, one below other. If one gets invisible, the next takes its place. Works well !!

    When layout = row: text-fields are positioned horizontally, from left to right. If one gets invisible, keeps occupying space. Does NOT work.

  8. #8
    Join Date
    Aug 2016
    Posts
    142

    Default

    I'm using 5.4

    Perhaps there is a bug in 3.8 or the feature for row layout was not implemented in that version?

  9. #9
    Join Date
    Nov 2017
    Posts
    8

    Default

    Deanicus: this seems to be a bug that occurs in some versions ...

    Regression: Hide column without leaving blank space (invisible-consumes-space and row layout)


    http://jira.pentaho.com/browse/PRD-4760
    Last edited by eyassunaga; 12-12-2017 at 04:16 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.