Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Executing Powershell Script Doesn't Proceed

  1. #1
    Join Date
    Dec 2017
    Posts
    2

    Default Executing Powershell Script Doesn't Proceed

    Hi Guys

    New to PDI and a bit stumped so hoping someone can help me.

    I want to download a pricing file from a website to Import into a database. The problem is that this file is generated by the website and takes about 10-20seconds to generate and then returns a zip file different from the URL link to download. I have tried using the HTTP and Copy files steps but they just return 0 bytes files on the destination folder. it feels that they dont wait for the file to download and proceed as successful.

    I have had success downloading the file with a powershell command -> (new-object System.Net.WebClient).DownloadFile('Inputlink','Outputfile')

    I have tried executing it through a bat file in the execute a process step and also through execute shell. I have specified exit commands in the powershell script file as well as the bat but still the particular step just "hangs" and doesnt proceed even though the file is successfully downloaded. How do i get the step to proceed ?

    Any help will be much appreciated.

    Am using PDI 7.1

  2. #2
    Join Date
    Dec 2017
    Posts
    2

    Default

    Solved the problem with a workaround. I use this command line downloader - https://aria2.github.io/ and just execute it as a shell script. Would still like to resolve the powershell script issue

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.