Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Text file output and Metadata Injection

  1. #1

    Default Text file output and Metadata Injection


    I have a problem with the length of the fields in the Text File Output Step (Kettle 6.0.1).

    I read the data with a table input and then I have to write them into i csv file. If I push "Get Fields" in the Fields tab, the length of every field becomes fixed and I have white spaces at the end of every value (if its length ifs less than the fixed value). So, i have to leave blank the length value for every attribute in the stream.

    Now I'm using the ETL Metadata Injection step. I'm using an Add Constant step in order to create a blank attribute. Nevertheless, whenI use it as length for the text field output step, I have the white spaces. I have also tried setting a value (1000), but I have the same number of white spaces,. I've also tried enabling "Right pad fields" in the content tab, but nothing. It seems that I'm not able to pass the value of the length using the Metadata Injection.

    Have you an idea about what is wrong?

    Thank you!

  2. #2
    Join Date
    Jun 2012


    Have you tried Text-File-Output option "Fast data dump"?
    So long, and thanks for all the fish.

  3. #3


    It works!
    Thank you very much!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.