Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: unexpected IDENT in: "truncate"

  1. #1
    Join Date
    Nov 2017

    Default unexpected IDENT in: "truncate"

    I have a kettle job that is running every night but it has recently stopped working. It fails on the first transformation when it tries to truncate a table. The "pentaho.log" shows an error message of "syntax error, unexpected IDENT in: "truncate"". When I run the job myself manually it completes with no errors. I have tried dropping the table in question and then re-creating it but that has not helped. I am not familiar with this error message so any insight into this situation would be appreciated.

  2. #2
    Join Date
    Jun 2012


    You must have changed something to make that job fail recently, and you don't recall what exactly you changed?
    Try to find out the exact SQL command used for truncating the table.
    Could be it shows up in your job log (debug level).
    If not, browse your server log.

    You shouldn't get the same "truncate" related message, when you drop and recreate the table without the truncate table option.

    As a workaround you could explicitly truncate the table by issuing a "DELETE * FROM ${}" in a SQL job entry.
    So long, and thanks for all the fish.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.