Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Saiku Analytics plugin doesn't load

  1. #1
    Join Date
    May 2014

    Default Saiku Analytics plugin doesn't load

    We're trying to install Saiku Analytics on Pentaho server CE 8.0. Our production server uses a PostgreSQL back-end for its Jackrabbit, Hibernate and Quartz, CAS for single sign-on, and we access it through an Apache server which is configured for HTTPS traffic and connects to Tomcat using AJP protocol. It appears this may be causing some problems.
    We tried the installation on our local machines: on a clean server, on a clean server with a DB back-end, and on a clean server with CAS. Saiku worked fine on every try. But on the production server, it doesn't even load. It's perpetually stuck on the "Loading" message with Saiku logo. At first we suspected a license problem, so we removed the license to see if we get the "missing license" error message - Saiku doesn't even get that far.
    Has anybody had a similar problem?

  2. #2
    Join Date
    May 2014


    In the end I solved it.
    There is a jQuery call to /pentaho/plugin/saiku/api/load/plugin/plugins which for whatever reason fails on our environment. But the results are not used for anything, so the call is useless. I edited this file:
    on line 100, removed the REST call so that the session is created, and it now works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.