Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Transformation runs fine from Windows command line or scheduled job, fails from GUI

  1. #1

    Question Transformation runs fine from Windows command line or scheduled job, fails from GUI

    I am debugging some issue in a transformation. When I run it in Spoon GUI, it fails because one step is getting different amount of fields from 2 input streams. This happens on both my Test and Production machine. When I run the exact same transformation from the command line with Pan, it runs fine. Also the job that ran last night had this transformation and there it also ran fine. Any idea what is wrong there?

  2. #2
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Is the step that's failing a "Get data from XML" step by chance?
    That's the only step that I can think of that does field layout checks at run time. Everything else only checks during design - and won't let you build a bad design.

    You are required to have a consistent field layout for all incoming streams into a step.

  3. #3

    Default

    No, it's the sort step that gives the errors. The GUI is right, there is a different amount of fields. I failed to drop one field that I thought would be dropped because its value is used to replace the value of another field. So I'm more surprised that from the command line and Windows Scheduler in a job it seems to run without errors.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.