I'm in the process of migrating our Pentaho 6.1 environment to 8x. I use kettle and spoon and have the kettle repository in a database (Oracle). I could have sworn when you tried to open a repository that was of an earlier version than your current environment you'd be prompted to upgrade which in turn would issue some ddl on the backend db.