Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Pentaho user console scheduler multiple lines for one job

  1. #1
    Join Date
    Dec 2016
    Posts
    2

    Default Pentaho user console scheduler multiple lines for one job

    Hi!

    There is strange behavior of pentaho quartz scheduler.
    I made simple test job named "test_job_3_min" that work 3 minutes long, upload it on server through user console and set schedule that launch it every minute.
    Inside job I made standard logging every 5 sec to DB table and check if there is a copy of "test_job_3_min" launched.
    So there is only one copy of this job working at every moment of a time.
    I can see that one in three launches succeeded.
    Name:  pentaho_job_launches.jpg
Views: 220
Size:  69.1 KB

    This is all ok and working fine, but in PUC Schedules section I can see strange lines for my job with status "Finished" along with main every minute schedule.
    Some time there is one line with empty Last Run and Next Run. Some time there is one more line with Last Run specified.
    Schedule for that lines is also strange - no duration specified "Every at <time>".

    Name:  pentaho_processes.jpg
Views: 137
Size:  4.5 KB

    When I set schedule to launch job every 10 sec amount of these lines become grow and some of them have status Normal.

    Name:  pentaho_job_launches_10_sec.jpg
Views: 146
Size:  10.2 KB

    Can somebody explain what's this can be?
    If this is normal, can I disable PUC from showing these processes?

    Pentaho Server version 7.1.0.0-12, build 1 from 2017-05-16 17.18.02 by buildguy

    Job attached in archive: test_job_3_min.zip

    UPD: left job working for the night and got 250+ lines with "test_job_3_min" in my schedule now.
    This is bad, because we plan to have several such jobs scheduled to launch every 15-30 minutes.
    It's will be bloody mess there... I think it's a bug and for one job must be only one line.
    What we can do? Upgrade to Pentaho 8?

    UPD2: lines are disappeared after Pentaho Server restart, but this is not a case
    Last edited by Skiv; 02-22-2018 at 02:58 AM.

  2. #2
    Join Date
    Dec 2016
    Posts
    2

    Default

    Hi, it's seems that I found the solution:
    Set org.quartz.jobStore.misfireThreshold = 5000 in file pentaho-server/pentaho-solutions/system/quartz/quartz.properties
    By default threshold is 60000 ms (one minute). No more redundant lines appeared in schedule for my job.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.