Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Kettle jobs going zombie

  1. #1

    Unhappy Kettle jobs going zombie

    We've been having some intermittent hanging of jobs lately with DI 6.1 that has been causing us a fair amount of trouble. Unfortunately, we haven't been able to narrow down any cause for it so I am hoping someone here can help us.

    The jobs in question are scheduled ETL jobs that run every half hour on our Linux servers and move data between our transactional db and the datamart db. Since we have some larger jobs that also run on those boxes and use some of the same tables we have a system set up that prevents new jobs from kicking off if any kitchen job is still running when it starts up. These processes usually only take about 7-15 minutes to run, so having one of them get stuck and hold everything up for hours causes a lot of problems.

    Has anyone else had issues with kettle jobs turning zombie on Linux? They can't be stopped normally, we have to use kill -9 on them to get rid of them. We have had a few occasions where a process will recover after a few hours and finish but usually they've gone full zombie and need to be killed in order to free up our system and let the jobs run on schedule again.

    So far we haven't seen any errors or warnings in the logs when this happens, even with logging changed to detailed. The process simply stops responding or logging anything at that point. Memory and CPU usage on the linux boxes doesn't seem to be spiking or maxed out, nor are the MySQL boxes showing any locking issues or any other problems in their logs.

    Another complicating factor is that they do not seem to hang at any single point in the jobs or at any consistent time. I've seen them hang in the middle of jobs, right after jobs, and even after the very last job/transaction of the overall project when there is literally no work left to be done.

    I'm at my wits end here, so any suggestions would be welcome!

  2. #2

    Default

    This sounds like an issue I have on a Windows box with PDI 7. What does the logging of individual transformations say?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.