Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Got Error after successful run

  1. #1
    Join Date
    Aug 2017
    Posts
    6

    Default Got Error after successful run

    Hi All,

    my job runs properly, files are on the expected place, transfomation are successfull as well so the scheduled job works as expected, but I always got an email after run as it fails!
    Does somebody facing with the same issue?


    Error message:

    ERROR (version 6.1.0.1-196, build 1 from 2016-04-07 12.08.49 by buildguy) : Error while trying to send files. Exception :
    3: Permission denied
    Permission denied
    ERROR (version 6.1.0.1-196, build 1 from 2016-04-07 12.08.49 by buildguy) : org.pentaho.di.core.exception.KettleJobException:
    3: Permission denied
    Permission denied


    at org.pentaho.di.job.entries.sftp.SFTPClient.put(SFTPClient.java:261)
    at org.pentaho.di.job.entries.sftpput.JobEntrySFTPPUT.execute(JobEntrySFTPPUT.java:887)
    at org.pentaho.di.job.Job.execute(Job.java:723)
    at org.pentaho.di.job.Job.execute(Job.java:864)
    at org.pentaho.di.job.Job.execute(Job.java:864)
    at org.pentaho.di.job.Job.execute(Job.java:864)
    at org.pentaho.di.job.Job.execute(Job.java:864)
    at org.pentaho.di.job.Job.execute(Job.java:864)
    at org.pentaho.di.job.Job.execute(Job.java:864)
    at org.pentaho.di.job.Job.execute(Job.java:864)
    at org.pentaho.di.job.Job.execute(Job.java:864)
    at org.pentaho.di.job.Job.execute(Job.java:545)
    at org.pentaho.di.job.Job.run(Job.java:435)
    Caused by: 3: Permission denied
    at com.jcraft.jsch.ChannelSftp.throwStatusError(ChannelSftp.java:2491)
    at com.jcraft.jsch.ChannelSftp._put(ChannelSftp.java:528)
    at com.jcraft.jsch.ChannelSftp.put(ChannelSftp.java:480)
    at org.pentaho.di.job.entries.sftp.SFTPClient.put(SFTPClient.java:259)
    ... 12 more

  2. #2

    Default

    I have different issues with running jobs. Your error message suggests you have an authentication issue somewhere.

  3. #3
    Join Date
    Aug 2017
    Posts
    6

    Default

    Yes looks like authentication issue, but I always get this message even if it puts the file to the target or not and if I did not check the logs I cannot figure it out if it was successful or not.
    Otherwise my job has 4 put sftp statement and based on the logs only the last one get this message others are good.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.