Hi to all,
there's a strange bug in the latest BA-SERVER platform (tested in 7.1 and 8.1)

Step to reproduce:
- publish a report with parameter and set the default output type as Excel (or even others file type output "application/rtf", "application/vnd.ms-excel", "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet", "text/csv", "mime-message/text/html")
- access the ba-server but not with localhost:8080 so for example 10.232.1.49:8080/pentaho
- open the report and set the parameter without touching output format
- click view report for downloading the xls file
- change the parameter and click view report again
Result is white page and no file downloaded, you have to refresh the page to start back from pentaho home.

Strangely enough if you access pentaho through localhost it works with the latest version of firefox but not with chrome.
If you change the output type to a non-file output (so maybe html paginated) and you click view report, than you change back to excel and view report it works all the time.

The problem is totally in the html/js page, because the server does not log anything, you can clearly see that the report is acquired through some GET and a final POST that start the file download.
In the second run the report is correctly called, but the final POST is never sended from the client (the web page)

I think the error is on reportviewer-app.js, maybe something when is called "_isDownloadableFormat" and timeout is checked...
In BA-SERVER 6.1 everything works well, but when reportviewer-app.js were completely refactored since version 7 the problem is introduced.

Any hints for fixing this?

Thank to all