Hello,
today I need your advice please.

Until today we used: pdi-ce-7.1.0.0-12: We installed the plugin: „Advanced http“ in pdi-ce-7.1.0.0-12/data-integration/plugins/steps/ --> Alls works fine.

Since today we use: pdi-ce-8.1.0.0-365: We installed the plugin: „Advanced http“ in pdi-ce-8.1.0.0-365/data-integration/plugins/steps/ --> Error Messages occurs no success

I tried the following (using the OSs: Windows 10 and CentOS 7)

Using Spoon with new 8.1.x.x.x version leads in the following error:
Failed to execute runnable (java.lang.NoClassDefFoundError: org/apache/commons/httpclient/protocol/ProtocolSocketFactory)

Using Pan with new 8.1.x.x.x version leads in the following error:
2018/11/15 14:49:42 - Transformation11 - Dispatching started for transformation [Transformation11]
log4j:ERROR No output stream or file set for the appender named [pdi-execution-appender].
java.lang.NoClassDefFoundError: org/apache/commons/httpclient/protocol/ProtocolSocketFactory
at com.bpa.pentaho.plugins.AdvancedHTTPMeta.getStep(AdvancedHTTPMeta.java:636)
at org.pentaho.di.trans.Trans.prepareExecution(Trans.java:918)
at org.pentaho.di.trans.Trans.execute(Trans.java:627)
at org.pentaho.di.pan.PanCommandExecutor.execute(PanCommandExecutor.java:167)
at org.pentaho.di.pan.Pan.main(Pan.java:230)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.pentaho.commons.launcher.Launcher.main(Launcher.java:92)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.httpclient.protocol.ProtocolSocketFactory
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at org.pentaho.di.core.plugins.KettleURLClassLoader.loadClassFromParent(KettleURLClassLoader.java:94)
at org.pentaho.di.core.plugins.KettleURLClassLoader.loadClass(KettleURLClassLoader.java:114)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 10 more
~


Do I have misconfigured the plugin?

Thank you for helping me!

Thorsten