Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Password not getting updated after recreating a user till server restart

  1. #1

    Default Password not getting updated after recreating a user till server restart

    Password not getting updated after recreating a user till server restart
    The issue can be reproduced by following below steps
    1. Log onto pentaho user console as administrator and create a user with a password
    2. Delete the created user
    3. Create the same user with different password
    4. Try to log on using the new password and it will not allow while using the old password it get through.
    5. Restart the server and now the new password works.

    User credentials getting cached?
    The update password on admin console works flawlessly.

  2. #2
    Join Date
    Jul 2013
    Posts
    7

    Default

    I am having the same issue as Vineeth, we have pentaho bi 7.1 ( i even tried on 7.0, 8.2) and the behavior is the same.
    we have user and roles assigned to specific folders on the report files. when i change the user to specific roles, and the user sign out - sign it the changes doesnt get reflected. just until i restart the whole bi server. when i look at the looks seems like the server find the session already cache .
    [org.springframework.security.web.access.intercept.FilterSecurityInterceptor] Previously Authenticated: org.springframework.security.authentication.UsernamePasswordAuthenticatio
    nToken@cdf371df: Principal: org.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2017 Pentaho Corporation. All Rights Reserved.