Hitachi Vantara Pentaho Community Forums
Results 1 to 1 of 1

Thread: Table input step problem when using substring function on Firebird 3.x

  1. #1
    Join Date
    Jun 2016
    Posts
    1

    Default Table input step problem when using substring function on Firebird 3.x

    Hi

    I really need your help, have tested everything that comes to mind.

    We have pdi job, that is loading data from Firebird, firebird was upgraded to version 3 (previously was 2).

    I changed the drivers by replacing the firebird driver to data-integration/lib/jaybird-full-3.0.5.jar and i have the following problem now, see attached screenshot, the funny thing is i tested with two separate spoons, same version, extracted from sourceforge archive at different times but should be same setup with same firebird drivers, one works without problems the other one renames the field to SUBSTRING as you can see from the screenshot.

    Same thing happens on live linux carte server, working on spoon/master server but not on centos server running carte. No matter which version or driver i use, have tried most of the major versions from 5-8.2 PDI.

    https://imgur.com/QaxAw5e

    https://imgur.com/cBBkr9C

    Br
    Last edited by noomster; 05-08-2019 at 02:25 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.