Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Changing the default port number

  1. #1
    Join Date
    Aug 2005
    Posts
    3

    Default Changing the default port number

    Hi,

    I have another service running on port 8080, which I'd prefer not to move. I was able to change most of the instances in the pentaho-demo (hasn't anyone mentioned to the jboss developers recently that hardcoding port numbers is rude?).
    I've also been able to change most of the references in pentaho-demo. (Just a comment, but hard coded port numbers are rude )

    I've found most of them, but I haven't found the instances which the page "A Collection of Samples and Examples" is using. The page is generated by Navigate.jsp&&solution=samples All the other pages load fine on the new, correct port.

    Any suggestions would be appreciated.
    Evelyn

  2. #2
    Join Date
    Aug 2005
    Posts
    3

    Default Re:Changing the default port number

    Evelyn,

    The port number in pentaho-demo are hardcoded only within the static html pages (index.html, settings.html)located at PENTAHO_DEMO_ROOT/jboss/server/default/deploy/pentaho.war/jsp.
    I recommend to change all of the 'http://localhost:8080/pentaho' entries with the relative path '/pentaho'.

    The jboss does not hardcode any port numbers (at least I know nothing about such practices).

    The 8080 port number is configured in the tomcat server.xml configuration file located in PENTAHO_DEMO_ROOT/jboss/server/default/deploy/jbossweb-tomcat55.sar
    Change the '<Context port="8080" ...' entry to the port number that fits your needs. You may change the other connectors ports as well.

    According to the "Pentaho Quick Start" guide you should add the following entry to the
    PENTAHO_DEMO_ROOT/jboss/server/default/deploy/pentaho.war/WEB-INF/web.xml file:
    <context-param>
    <param-name>base-url</param-name>
    <param-value>http://localhost:your-port/pentaho</param-value>
    </context-param>

    (I assume you are running preconfigured pentaho-demo installation).

    Hope this helps
    Grzegorz

    Post edited by: grsw, at: 08/27/2005 12:42

  3. #3
    Join Date
    Aug 2005
    Posts
    3

    Default Re:Changing the default port number

    grsw wrote:
    The port number in pentaho-demo are hardcoded only within the static html pages (index.html, settings.html)located at PENTAHO_DEMO_ROOT/jboss/server/default/deploy/pentaho.war/jsp.
    I recommend to change all of the 'http://localhost:8080/pentaho' entries with the relative path '/pentaho'.
    I changed the port numbers in these two files, to my new port number.

    The jboss does not hardcode any port numbers (at least I know nothing about such practices).
    I found instances of a hard coded port number in jboss/:
    ./server/default/deploy/http-invoker.sar/META-INF/jboss-service.xml
    ./server/default/deploy/jbossweb-tomcat55.sar/server.xml
    ./server/default/deploy/pentaho.war/jsp/index.html
    ./server/default/deploy/pentaho.war/jsp/settings.html

    The 8080 port number is configured in the tomcat configuration file located in PENTAHO_DEMO_ROOT/jboss/server/default/deploy/jbossweb-tomcat55.sar
    Change the '
    This looks incomplete.

    To follow up, I was able to invoke all of the example with the new port number directly as an url. The old port number is coming up within the navigator web pages:
    http://localhost:18080/pentaho/jsp/N...lution=samples
    (notice I've changed the port number there)
    And, I'm able to directly go to the referred page:
    http://localhost:8080/pentaho/jsp/Na...tarted&action=
    if I change the port number to 18080
    (which suggests to me that only the generation of the navigation page is missing the new port number, and that the back end knows of the new port number).

    Thanks for the quick reply on a Saturday!

    Post edited by: emitchell, at: 08/27/2005 12:42

  4. #4
    Join Date
    Aug 2005
    Posts
    3

    Default Re:Changing the default port number

    This forum board software is really a "beta version", so it cutted my post. I edited it changing all triangle braces into the appropriate HTML entities, and now the post is complete and readable (I hope).

    The jboss files you listed are the configuration files, so I cannot say the port numbers specified in those file are 'hardcoded'.

    Regards
    Grzegorz

    Post edited by: grsw, at: 08/27/2005 12:49

  5. #5
    Join Date
    Aug 2005
    Posts
    3

    Default Re:Changing the default port number

    This helps quite a bit! Things are working as I expect now.

    I would have found that particular place to change the port, if the file would have contained the string '8080' or 'localhost'. Perhaps adding this to the demo version of
    pentaho-demo/jboss/server/default/deploy/pentaho.war/WEB-INF/web.xml would be helpful for others.

    Thank you!
    Evelyn

  6. #6
    jdixon Guest

    Default Re:Changing the default port number

    Hi Guys,

    Sorry about the port numbers in the samples files. We are removing them so that you don't have this problem with future releases.

    James Dixon
    Chief Geek
    pentaho.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.