Hitachi Vantara Pentaho Community Forums
Results 1 to 12 of 12

Thread: Installation Issues

  1. #1
    Join Date
    Nov 2005
    Posts
    2

    Default Installation Issues

    I am trying to install the war version, not the demo.

    I managed to start it up using TomCat, but whenever I click on any of the available options such as the Hello World example nothing works.

    Just to get it straight, I installed

    pentaho-solutions in "C:\\pentaho-solutions"
    pentaho-war in "C:\\tomcat\\webapps\\"
    pentaho-style in "C:\\tomcat\\webapps\\"
    pentaho-data in "C:\\tomcat\\webapps\\" and "C:\\pentaho-solutions"

    I added the database connections as specified in the Advanced Install Guide.

    The following is the error message when trying to open Hello World example:

    type Exception report

    message

    description The server encountered an internal error () that prevented it from fulfilling this request.

    exception

    org.pentaho.repository.RepositoryException: HIBUTIL.ERROR_0004 - beginTransaction() failed.
    org.pentaho.repository.HibernateUtil.beginTransaction(Unknown Source)
    org.pentaho.repository.runtime.RuntimeRepository.setSession(Unknown Source)
    org.pentaho.repository.runtime.RuntimeRepository.getInstance(Unknown Source)
    org.pentaho.solution.SolutionEngine.execute(Unknown Source)
    org.pentaho.services.BaseRequestHandler.handleActionRequest(Unknown Source)
    org.pentaho.ui.servlet.ViewAction.doGet(Unknown Source)
    javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
    javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

    Thanks!

  2. #2
    gmoran Guest

    Default Re:Installation Issues

    Hi!
    Just to check some straight forward things first, did you run the start_hypersonic.bat file in the pentaho-data directory? This script fires up the databases and must be run before you start your app server.

    Next, is the .war that you are using from the 0.9.7.3 release, or is this a .war you built yourself for the latest release? And also can you find the exception in your server.log and post it, it may give us more details.

    We'll get you up and running ASAP!

    best regards,
    Gretchen

  3. #3
    Join Date
    Nov 2005
    Posts
    2

    Default Re:Installation Issues

    Hi,

    I am using the pre-compiled version 0.9.7.3. I just put the WAR file in the webapps directory.

    About the data source, I started it by using start_hypersonic.bat and I think it worked because it says Succesful at the end.

    Also I am attaching the logfile found in TomCat logs.

    Thanks once again! http://forums.pentaho.org/archived_a...2005-11-10.txt

    Post edited by: algatt, at: 11/10/2005 11:06

  4. #4
    Join Date
    Nov 2005
    Posts
    1

    Default Re:Installation Issues

    I am getting the same "beginTransaction() failed" error message, but my Tomcat log shows:

    Caused by: org.apache.commons.dbcp.SQLNestedException: Cannot create JDBC driver of class '' for connect URL 'null'
    at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:780)
    at org.apache.commons.dbcp.BasicDataSource.getConnection(BasicDataSource.java:540)
    at org.hibernate.connection.DatasourceConnectionProvider.getConnection(DatasourceConnectionProvider.java:59)
    at org.hibernate.jdbc.ConnectionManager.openConnection(ConnectionManager.java:298)
    ... 38 more
    Caused by: java.sql.SQLException: No suitable driver
    at java.sql.DriverManager.getDriver(DriverManager.java:243)
    at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:773)

  5. #5
    gmoran Guest

    Default Re:Installation Issues

    Hi there,

    The exception you are receiving indicates that hibernate cannot find the jdbc driver needed to talk to the database:

    "Caused by: java.sql.SQLException: No suitable driver"

    The first line in the exception leads me to believe that your configuration parameters are empty (a separate issue):


    "Caused by: org.apache.commons.dbcp.SQLNestedException: Cannot create JDBC driver of class '' for connect URL 'null' "

    You may want to revisit the Advanced Installation Guide, which tells you how and where you need to set up the connection strings for Tomcat with the Pentaho BI platform.

    Also be sure that the hsqldb.jar file (the Hypersonic jdbc driver jar) is in the endorsed directory for Tomcat, typically under {tomcat_home}/common/endorsed.

    Let me know if I can be of further assistance
    Best Regards,
    Gretchen

    Post edited by: gmoran, at: 11/16/2005 15:35

  6. #6

    Default Re:Installation Issues

    I am trying to deploy pentaho.war to tomcat 5.5.9

    Pentaho BI was successfully deployed to tomcat as I saw the greeting
    from Pentaho BI platform.
    However, I got an error when accessing "Sample Data" in "Getting started" samples:

    Error: ConnectFactory.ERROR_0001 - Database connection could not be established to: SampleData (org.pentaho.component.SQLLookupRule)


    "MDX Query" in "DataSource Examples" was successfully executed, but I got the same
    errors when accessing "SQL Query of Managers for Departments" sample in "DataSource Examples".

    Would someone help me to figure it out?

    I did all the steps in Advanced Install Guide (for tomcat5):
    - extract pentaho-solutions to \\webapps
    - successfully run hypersonic database
    - copy hsqldb.jar to \\common\\endorsed
    - put pentaho.war (I created using ant 1.6.5) to \\webapps
    - add jndi datasource mappings to \\conf\\server.xml

    I attached my tomcat "server.xml". http://forums.pentaho.org/archived_att/files/server.xml

  7. #7
    Join Date
    Nov 1999
    Posts
    579

    Default Re:Installation Issues

    Hey there,

    I reviewed the attached server.xml, and I think I may see the problem. The DefaultContext node that was added as added directly under the Server node. That is, your file shows DefaultContext's parent is Server. As far as I know, DefaultContext may only be inside the Host tag (deeper down). In other words, I believe you need to cut out your whole DefaultContext node, and paste into the file so that it's parent is Host.

    Hope that helps,

    Marc

  8. #8
    Join Date
    Jan 2006
    Posts
    4

    Default Re:Installation Issues

    I dis move the whole DefaultContext node to be under Host tag. but it does not make any difference -- still not able to connect to the db. Attached below are the the logs indicating the problem in server.log:

    ------------------------------------------------------------------------------------

    2006-01-22 20:10:17,634 ERROR [org.pentaho.jasper.JasperReportsComponent] Error Start: Pentaho 1.0.0.0 build 156
    2006-01-22 20:10:17,634 ERROR [org.pentaho.jasper.JasperReportsComponent] 65809d76-8bb5-11da-b9a2-19e5aa544cce:COMPONENT:context-9073930-1137982216963:jasper-reports-test-1.xaction JasperReport.ERROR_0016 - Error connecting to the database
    org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create JDBC driver of class '' for connect URL 'null'
    at org.apache.tomcat.dbcp.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:780)
    at org.apache.tomcat.dbcp.dbcp.BasicDataSource.getConnection(BasicDataSource.java:540)
    at org.pentaho.jasper.JasperReportsComponent.getConnection(Unknown Source)
    at org.pentaho.jasper.JasperReportsComponent.executeAction(Unknown Source)
    at org.pentaho.component.ComponentBase.execute(Unknown Source)
    at org.pentaho.runtime.RuntimeContext.executeComponent(Unknown Source)
    at org.pentaho.runtime.RuntimeContext.executeAction(Unknown Source)
    at org.pentaho.runtime.RuntimeContext.executeLoop(Unknown Source)
    at org.pentaho.runtime.RuntimeContext.executeSequence(Unknown Source)
    at org.pentaho.runtime.RuntimeContext.executeSequence(Unknown Source)
    at org.pentaho.solution.SolutionEngine.execute(Unknown Source)
    at org.pentaho.services.BaseRequestHandler.handleActionRequest(Unknown Source)
    at org.pentaho.ui.servlet.ViewAction.doGet(Unknown Source)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:868)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:663)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Unknown Source)
    Caused by: java.sql.SQLException: No suitable driver
    at java.sql.DriverManager.getDriver(Unknown Source)
    at org.apache.tomcat.dbcp.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:773)
    ... 28 more
    2006-01-22 20:10:17,644 ERROR [org.pentaho.jasper.JasperReportsComponent] Error end:
    2006-01-22 20:10:17,644 ERROR [org.pentaho.runtime.RuntimeContext] 65809d76-8bb5-11da-b9a2-19e5aa544cce:RUNTIME:context-9073930-1137982216963:jasper-reports-test-1.xaction RuntimeContext.ERROR_0012 - ActionDefinition for org.pentaho.jasper.JasperReportsComponent did not execute successfully
    2006-01-22 20:10:17,644 ERROR [org.pentaho.solution.SolutionEngine] 65809d76-8bb5-11da-b9a2-19e5aa544cce:SOLUTION-ENGINE: jasper-reports-test-1.xactionSolutionEngine.ERROR_0007 - Action sequence execution failed

    ------------------------------------------------------------------------------------

    Thanks.

  9. #9
    Join Date
    Jan 2006
    Posts
    4

    Default Re:Installation Issues

    I did everything said in the Advanced Guide, including add the data source mapping (w/ DefaultContext tag) in to system.xml but is still not able to connect to the db. here is the error in system.log:

    19e5aa544cce:COMPONENT:context-9073930-1137982216963:jasper-reports-test-1.xaction JasperReport.ERROR_0016 - Error connecting to the database
    org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create JDBC driver of class '' for connect URL 'null'
    ... ...


    Thanks.

  10. #10
    Join Date
    Nov 1999
    Posts
    579

    Default Re:Installation Issues

    Hi,

    I'm sorry you're still having trouble.

    Are you also deploying to Tomcat (as opposed to using our Preconfigured Install)? If so, please attach your server.xml for me to review. Also, please make sure that you've copied your JDBC driver jar file(s) to the tomcat/common/lib directory.

    Finally, please attach your web.xml, and your action sequence).

    It may be simpler to create a .zip file with all the requested files in it so that you only have to upload one file.

  11. #11
    Join Date
    Jan 2006
    Posts
    4

    Default Re:Installation Issues

    1) Yes I deployed pentaho.war (built from j2ee package using ant 1.6.5) to Tomcat 5.5.
    2) I copied the sample data jdbc driver (hsqldb.jar) to tomcat5.5/common/endorce and/or to tomcat5.5/common/lib. I even tried to copy it to the shared/lib as I used to put my Postgresql driver over there (and it never had problem).
    3) I pasted the data source mapping (for hsql sample data) to system.xml.
    4) In the web.xml, I indicated where the Sample-solutions directory is.
    5) Attached below is the zip file including the requested docus (server.xml, report xaction file and pentaho.war web.xml).

    Thanks! http://forums.pentaho.org/archived_att/files/docs.zip

  12. #12
    Join Date
    Nov 2005
    Posts
    178

    Default Re:Installation Issues

    As explained in the forum post http://forums.pentaho.org/showthread.php?t=25895, Tomcat 5.5 changed the XML for the data source definition. Our documentation was written for Tomcat 5.0.

    Hope that resolves your data source issues.

    Anthony

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.