Hitachi Vantara Pentaho Community Forums
Results 1 to 13 of 13

Thread: Problems deploying pentaho.ear

  1. #1

    Default Problems deploying pentaho.ear

    I have deployed the Pentaho.ear file to JBOSS. When trying to open the url http://localhost:8080/pentaho/navigate the browser get stuck in waiting for localhost..

    I have attached my jboss log file:

    Post edited by: jerics99, at: 12/23/2005 06:43

    I can see in the log related to the JBOSS server start-up, that one of the paths in section CLASSPATH (see the beginning of the log) is incorrect; C:\\JBOSS\\jboss-4.0.2\\bin\\\\run.jar. I do not know what impact this may have?

    Another thing that I wonder about is when starting the db the log in the end it says something about Unknown Source , is that OK?

    C:\\Pentaho\\pentaho-data>java -cp lib\\hsqldb.jar org.hsqldb.Server -database.0 sa
    mpledata\\sampledata -dbname.0 sampledata -database.1 shark\\shark -dbname.1 shark
    -database.2 hibernate\\hibernate -dbname.2 hibernate -database.3 quartz\\quartz -
    dbname.3 quartz
    [Server@712c4e]: [Thread[main,5,main]]: checkRunning(false) entered
    [Server@712c4e]: [Thread[main,5,main]]: checkRunning(false) exited
    [Server@712c4e]: Startup sequence initiated from main() method
    [Server@712c4e]: Loaded properties from [C:\\Pentaho\\pentaho-data\\server.properti
    [Server@712c4e]: Initiating startup sequence...
    [Server@712c4e]: Server socket opened successfully in 141 ms.
    at org.hsqldb.persist.Logger.closeLog(Unknown Source)
    at org.hsqldb.Database.reopen(Unknown Source)
    at Source)
    at org.hsqldb.DatabaseManager.getDatabase(Unknown Source)
    at org.hsqldb.DatabaseManager.getDatabase(Unknown Source)
    at org.hsqldb.Server.openDatabases(Unknown Source)
    at Source)
    at org.hsqldb.Server.access$000(Unknown Source)
    at org.hsqldb.Server$ Source)

    Post edited by: jerics99, at: 12/23/2005 06:57

    I have just seen that the paths mentioned above is not presented right in the Forum (they look OK in edit mode though, but not as presented in the Forum), I am not sure why but maybe it is a language thing given that I am working from a Swedish Computer with local character set. However I have copied the message above and pasted it in to text document for you to see the paths correctly.

    I am really interested in The Pentaho Solution and I would like to be of support to make it successful in my region of the world!

    Post edited by: jerics99, at: 12/27/2005 06:38

    For your information, I tryed attach a rtf. file but got a error message saying that rtf is not a valid format for attachments to the Forum. The strange thing is that I can not after that save any file attachments, the browse control is gone for my message the only browse control left is the one for attaching pictures, this has to be a bugg in the Forum. I am adding the attachment to sibling message of this posting.

    Post edited by: jerics99, at: 12/27/2005 06:43

  2. #2

    Default Re:Problems deploying pentaho.ear

    Here is the attached file mentioned in my previous posting.

  3. #3
    gmoran Guest

    Default Re:Problems deploying pentaho.ear

    Hey there,

    This same error has been reported once before, but the member did not tell us how or if he resolved it, and unfortunately my best attempts to reproduce it on my side have failed.

    We definitely want to resolve this problem, so if you would be so kind as to take a couple of extra steps, we can debug this problem.

    The message regarding "java.lang.NoClassDefFound..." is a big problem - the end result of that error is that your databases did not start up. And you definitely need those for the platform to operate correctly.

    So, here is my suggestion - download the pre-configured install (the platform demo, named pentaho-demo-{version}.zip , found at BE SURE YOU DOWNLOAD THE SAME VERSION OF THE DEMO AS THE FILES YOU WERE ORIGINALLY WORKING WITH. Our tests will not be valid if the versions are not the same, and could potentially confuse the matter even more if you try to run mismatched versions of the platform and databases. The ideal test would be to make sure all of your files (including the war and databases you are trying to deploy) are our 1.0 GA release version.

    The demo takes about 5 minutes to install and run, instructions for this can be found at in our Quick Start Guide.

    Once you start the demo, you will notice that the main startup file (start_pentaho.bat) calls a subsequent file (start_hypersonic.bat)that will start a copy of the databases.

    Did the databases startup OK from the demo, or did they too fail with the same error?

    If the demo databases started fine, then I would presume there is a problem with the database files that you were using. You can compare the two database file directories and try to determine their differences - or you can start the databases from the demo STANDALONE ( just run the start_hypersonic.bat from the demo/data directory) and try running your deployed application.

    If the demo databases fail, then we have some other classpath issue that is interfering with the proper startup of the hypersonic databases. Note that the startup of the databases only depend on the appropriate hsqldb.jar being recognized (this jar file lives in the data/lib directory of the database files), and a JRE.

    What OS are you using exactly, and what JDK?

    Let me know how this goes, or if you find this all completely confusing, come on back and we can take it one step (question) at a time. Dont worry, we'll get it worked out


  4. #4

    Default Re:Problems deploying pentaho.ear

    The version of the database I am using is build 156 according to the releasenotes.txt (found in the same directory as the start_hypersonic.bat file).

    My OS is Windows Server 2003 Enterprise Edition and JBOSS 4.0.2

    I have attached the logs.

    I can not see any differences in the directory structure when comparing the data folders of the demo to the sample deployment install.

    For your information, I tested the demo install by using the pre-defined collection of examples verifying the features as ready for use.

    Post edited by: jerics99, at: 12/29/2005 04:43

    I am using Java 2 Platform, Enterprise Edition 1.4 SDK.

    Post edited by: jerics99, at: 12/29/2005 08:24

  5. #5
    gmoran Guest

    Default Re:Problems deploying pentaho.ear

    This is all good news! Since the demo databases started correctly, you can swap out the files that were failing and use the demo database files instead. This will move you forward most quickly.

    You posted that you compared the directory structures of the the two database directories - but did you compare each file? You can use a file compare tool to do such things; I use Araxis Merge, which comes with a price, but is well worth it.

    You can also zip up the database files that are not working and send them to me, I would definitely like to investigate exactly what is causing the trouble for you. You can send those files to, with my name in the subject line, and they will get to me.

    Again, your quickest move forward is to copy out the data directory from the demo and use those files with your pentaho.ear deployment for JBoss.

    Please be sure to keep me up to date on your successes, I want to be sure you get this working!


    Post edited by: gmoran, at: 12/29/2005 11:22

  6. #6

    Default Re:Problems deploying pentaho.ear

    Gretchen thanks for your support!

    A strange thing is that the db seem to stop working when I move it to another place. When the data directory is in the default path of the demo it works but when moving it to the place where I have the db for my deployment I get the same problems as mentioned previously. Could this be a System path issue? I have tried changing the paths in the Environment Variables but without any success.

  7. #7
    gmoran Guest

    Default Re:Problems deploying pentaho.ear

    What Java JRE are you using? To find out for sure, check your $JAVA_HOME environment variable (if you have one) or the JRE/JDK specified on your system path.

    If you are running the demo, the JRE thats included in the {demo}/jre directory gets used. Outside of the demo, the default JRE/JDK set on your system gets used. I think we are narrowing down the problem to possibly a JRE issue.

    Also check to be sure there are no extraneous files in the data directories that could cause a problem - they usually are in the form of *.lck files that get left around sometimes by Hypersonic after the database has shutdown unexpectedly.


  8. #8

    Default Re:Problems deploying pentaho.ear

    I was using Java 2 Platform, Enterprise Edition 1.4 SDK, I was under the impression that it should work, and I have uninstalled that now and changed to Windows Platform - Java(TM) 2 Runtime Environment, Standard Edition 1.4.2_10 (I am not sure that this was necessary but I changed anyway). Me up to now mostly working with BI on Windows plattforms, Do you know the difference betweeen SDK and JRE?

    I have set the JAVA_HOME to C:#Program Files#Java#jre1.5.0_06. (I have in this posting used # instead of back-slash since those are not presented correctly in the Forum, probably given my regional setting, but in my environment I am of cource using back-slashes)

    For your information, when starting the preconfigured demo-db by using the Start-Pentaho.bat it seems like the Demo-db starts correctly, but when starting it from the start_hypersonic.bat (in the Data directory) it starts with previously reported problems.

    Post edited by: jerics99, at: 12/30/2005 05:00

  9. #9
    gmoran Guest

    Default Re:Problems deploying pentaho.ear

    OK, yeah, we have a couple of issues/ sources of confusion.

    First the difference between an SDK and a JRE is that the SDK is a complete developer's kit - meaning that the binaries to compile and debug Java are included in the package, as well as those files needed to run the Java application. A JRE is a Java Runtime Engine, basically a subset of an SDK, with only those files necessary to run the Java application.

    For the Pentaho platform, and for JBoss, you will want to have an SDK installed. An application server, in order to compile JSP (Java Server Pages) files on the fly, needs an SDK. The platform has several JSPs that need to compiled, so you will need to have an SDK installed.

    Your JAVA_HOME environment variable should point to the root directory of your installed SDK. So if you have installed the SDK to a directory c:/java/sdk1.4.2, then your JAVA_HOME should point to c:/java/sdk1.4.2. (note that the forward slashes are to overcome the forum backslash issue - you know Windows paths are backslashes).

    In your post, you reference "Java 2 Platform, Enterprise Edition 1.4 SDK" as the first SDK you were using. This is an SDK for J2EE development, which is server side Java. While this package bundles the Java 2 Standard Edition (1.4 bundles J2SE 5.0, which we have reported bugs between this SDK and the platform), this is more than what you need to run JBoss and the Pentaho platform. You need a Standard Edition SDK - the one that the platform is most tested around is the latest point release of Java 2 Standard Edition SDK 1.4.2.

    I'm also confused when you say that you installed the "Windows Platform - Java(TM) 2 Runtime
    Environment, Standard Edition 1.4.2_10", but your JAVA_HOME points to "C:/Program Files/Java/jre1.5.0_06". Your JAVA_HOME is poiinting to the original JRE that was installed with the 1.4 J2EE SDK I'm thinking.

    When you install the 1.4.2 J2SE SDK, you will need to be sure that your JAVA_HOME points to the root of your newly installed SDK, not an old JRE.

    Hope this all helps!

  10. #10

    Default Re:Problems deploying pentaho.ear

    I did the changes you asked me to in your previous posting but the db did still not work, I had the same problem as before. Anyway I have managed to get the solution to work now, however I do still not understand why. I created a bat-file as shown below. For your information my directory structure looks as follows (note forward slashes are to overcome the forum backslash issue):

    Data directory: C:/Pentaho/pentaho-data
    Java directory: C:/j2sdk1.4.2_10
    JBOSS directory: C:/JBOSS/jboss-4.0.2
    Pentaho Solutions directory: C:/JBOSS/jboss-4.0.2/pentaho-solutions

    System parameters are:
    Java_Home = C:/2sdk1.4.2_10/re
    JBOSS_HOME = C:/BOSS/boss-4.0.2/

    And I have also added to my path= C:/2sdk1.4.2_10/C:/2sdk1.4.2_10/in;

    This is the content of my bat file placed in the C:/entaho directory:

    @echo on
    set PENTAHO_PATH=C:/j2sdk1.4.2_10/
    set PATH=%PENTAHO_PATH%jre/bin
    cd pentaho-data

    I would appreciate some more information about this.

    I am now going to continue testing the work bench!!

    Regards, Eric

    Post edited by: jerics99, at: 01/03/2006 17:12

    Another issue that may be related to the problems described above is that when trying to start the workbench (vs by executing the PentahoWorkbench.exe I get the error message Required Java version 1.4.1 available 1.3.1_01

    Best Regards from a cold and snowy Stockholm!

    Post edited by: jerics99, at: 01/04/2006 05:53

  11. #11
    gmoran Guest

    Default Re:Problems deploying pentaho.ear

    The reason the batch file is working for you is because you are setting the java_home explicitly in the local session before you run the platform, or the hypersonic databases.

    This won't solve any problems for you outside of that batch file, because your environment still does not know where the correct JDK is. I gather that you also have a 1.3.1 JDK installed, since that is the JDK that Eclipse found (as noted in your post about the workbench complaining you have the wrong Java version).

    You need to set your OS environment's JAVA_HOME variable, similar to what you did in your batch file, in order for the 1.4.2 SDK to be picked up as your default Java version.

    If you go to your system properties, choose the Advanced tab, click the Environment Variables button, you will get the dialog where you need to set the JAVA_HOME environment variable.


  12. #12

    Default Re:Problems deploying pentaho.ear


    I have now updated my system environment with exactly the environment parameters of the Bat-file, the new paths seem to be equivalent to the previous ones that I have set. However I still have the same problems. I use bat files to be able to launch the sample database, the workbench and BIRT.

    I am rather sure that the Java version I use is the correct one. I have an Oracle client installed and I cane see that there are paths pointing at jre:s in the Oracle client directory, do you think my problems are related to this?


  13. #13
    gmoran Guest

    Default Re:Problems deploying pentaho.ear

    The fact that you have multiple JREs or JDKs installed on your system shouldn't (and i use that loosely cause problems - I have several on my systems at all times without issue. But something on your machine does seem to be interfering with your default settings. Sorry I couldn't be of more help. If you have access to another machine, you may want to try deploying the platform there, then after success, comparing the environments to help locate the problem.

    best regards,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.