Hitachi Vantara Pentaho Community Forums
Results 1 to 13 of 13

Thread: sun.jdbc.odbc driver problem in actionx!

  1. #1
    Join Date
    Mar 2006
    Posts
    7

    Default sun.jdbc.odbc driver problem in actionx!

    Hi! I just want to let you know that your project "Rocks"

    Using:BI Demo 1.1.1

    Trying to get a JRXML created by iReport 1.1.0 to work.
    I got an exampl working with the Report designer using the jdbc.odbc connection. But, I'm not able to get an action script woring.

    Also using in my *.actionx: configuring like said in the doc.
    Take a look a the actionx file (Attch)


    My Guess: Is that the sun.jdbc.odbc driver is already loaded! Do I need to add the driver lib (*.jar) to the Jboss/system/default/lib/ dir.



    Result:
    Error: JasperReport.ERROR_0003 - JDBC driver not specified. (org.pentaho.jasper.JasperReportsComponent)

    Debug: Starting execute of samples/reporting/DomaineDemographic.xaction (org.pentaho.solution.SolutionEngine)
    Debug: Getting runtime context and data (org.pentaho.solution.SolutionEngine)
    Debug: Loading action sequence definition file (org.pentaho.solution.SolutionEngine)
    Debug: audit: instanceId=1025c280-af2d-11da-a8b5-e5050c227a27, objectId=org.pentaho.runtime.RuntimeContext, messageType=action_sequence_start (org.pentaho.runtime.RuntimeContext)
    Debug: validateComponent validating component org.pentaho.jasper.JasperReportsComponent (org.pentaho.runtime.RuntimeContext)
    Debug: Validating component for action DomaineDemographic.xaction (org.pentaho.jasper.JasperReportsComponent)
    Debug: imageUrl is "{0}"getImage?image= (org.pentaho.jasper.JasperReportsComponent)
    Debug: imageDir is "{0}"system/tmp (org.pentaho.jasper.JasperReportsComponent)
    Debug: removeEmptyRows is {0}true (org.pentaho.jasper.JasperReportsComponent)
    Error: JasperReport.ERROR_0003 - JDBC driver not specified. (org.pentaho.jasper.JasperReportsComponent)
    Error: RuntimeContext.ERROR_0006 - Action components do not validate: DomaineDemographic.xaction (org.pentaho.runtime.RuntimeContext)
    Error: SolutionEngine.ERROR_0006 - Action sequence validation failed (org.pentaho.solution.SolutionEngine)

    Thanks!
    -Eric

    Post edited by: ericallard, at: 03/09/2006 01:34

    Post edited by: ericallard, at: 03/09/2006 01:48 http://forums.pentaho.org/archived_a...raphic.xaction

    Post edited by: ericallard, at: 03/09/2006 01:51

  2. #2

    Default Re:sun.jdbc.odbc driver problem in actionx!

    Hi,

    I have no experience with the exact JDBC you're using but, in order to connect to MySQL and MSSQL, it is necessary to put the *.jar in pentaho-demo/jboss/server/default/lib/

    Hope it works,
    Bruno

  3. #3
    Join Date
    Mar 2006
    Posts
    7

    Default Re:sun.jdbc.odbc driver problem in actionx!

    Thanks Bruno,

    In fact, I just want to conect to a MSACCESS!!! YES Access! Don't ask me why! Do you have an example of actionx file that would do this (using jasper reporting of pentaho)!

    I'm able to get it to work with the Report wizard using the sun.jdbc.odbc driver. So it must already be loaded by the wizard app. I just need to identify the *.jar file containing the driver!

    Also, if you have an axample for postGres (with the driver) that would be great!

    Cheers,
    -Eric

  4. #4

    Default Re:sun.jdbc.odbc driver problem in actionx!

    Sorry... never tried it!

    But I'll give you some hints that you might try. Right back telling what worked.

    1. I think you can find the JDBC-ODBC driver in a file called rt.jar ;

    2. You should copy it to /jboss/server/default/lib/

    3. Should make a JNDI to connect to your database in /jboss/server/default/deploy/ . I recommend taking a peek at sampledata-ds.xml

    Hope it's what you expected,
    Bruno

  5. #5
    Join Date
    Mar 2006
    Posts
    7

    Default Re:sun.jdbc.odbc driver problem in actionx!

    Thanks Bruno!

    I just tried your solution (helped with the doc) an I have the same result! Weird!

    First thing first!

    IN my cmd line: Java -version = 1.5.X - Is this a problem?
    I have JAVA_HOME pointing to a 1.4.2 SDK? Do you think this can be an issue! IS the BI platform running on 1.5?

    I'm wonderring why the Report wizard 0.9.2 works when using the same driver... in my configuration.?

    Thanks! I appreciate your time!
    -Eric

  6. #6

    Default Re:sun.jdbc.odbc driver problem in actionx!

    Hi again,

    I'm sorry you're still stuck with that. But hey, I'm sure you're having lots of fun!

    I gave it a try and made it with success!

    I've attached my example. Set it up as follows:

    1. Copy ODBC.xaction and ODBC.xml into your sample dir;
    2. Copy ODBC-ds.xml to pentaho-demo/jboss/server/default/deploy;
    3. Create a System DSN named dbtest pointing it to dbtest.mdb;
    4. Run your server...

    Hope it works,
    Bruno

    Post edited by: bpfonte, at: 03/09/2006 15:45

  7. #7

    Default Re:sun.jdbc.odbc driver problem in actionx!


  8. #8
    Join Date
    Mar 2006
    Posts
    7

    Default Re:sun.jdbc.odbc driver problem in actionx!

    Hi again!

    Thans for the quick response!!!
    I really appreciate!

    Your example worked! Great! I'm now trying to make it work on a Jasper (jrxml) report using an ODBC cnx. output HTML or PDF!

    Let me know if you're trying this scenario! We have a lot of Jasper reports we want to reuse!

    Cheers,
    -Eric

  9. #9

    Default Re:sun.jdbc.odbc driver problem in actionx!

    Hi,

    Any luck!?

    You should add your datasources references to /jboss/server/default/deploy/pentaho.war/WEB-INF/web.xml and to /jboss/server/default/deploy/pentaho.war/WEB-INF/jboss-web.xml. Copy the examples and pay attention to case (http://forums.pentaho.org/showthread.php?t=26054).

    I'm sure you already know but a complete guide on how to Jasper your data is in Creating_Pentaho_Solutions_1.1.1.pdf.

    Regards,
    Bruno

  10. #10
    Join Date
    Mar 2006
    Posts
    7

    Default Re:sun.jdbc.odbc driver problem in actionx!

    Hi Bruno!
    Thanks a lot .. I got it to work with the PDF format! T

    Isssue:
    here's seems to be an issue with the HTML one. I found that's trying to write(images) to a local path containing the following tag! getImage?image=

    Found in jasperrepport-conf.xml! Obviously it fails!
    Now I'll try to make the sub-report to work properly! Any issue you know about them?

    An working on this project part-time… But I like what I see!

    Another question: Do you thing Pentaho can take *.Jasper (compiled) as an input! With the associated jasperrepports.jar lib!
    We're working on Jasperreppors-1.1.1
    Let me know! And thanks again!
    I appreciate!

    Cheers,
    -Eric

  11. #11

    Default Re:sun.jdbc.odbc driver problem in actionx!

    Sorry... that's too much for me. Anyone else cares to help?!

    Post edited by: bpfonte, at: 03/10/2006 11:10

  12. #12
    Join Date
    Jul 2006
    Posts
    24

    Default Re:sun.jdbc.odbc driver problem in actionx!

    getImage?image= is actually a folder in your pentaho-solutions directory. Can you just change that path in the .xml to point to a different folder?

  13. #13
    dmoran Guest

    Default Re:sun.jdbc.odbc driver problem in actionx!

    If you specify a resource that ends with .jasper then it will be used as a compiled report def. Otherwise, the component strips off the extension, appends .jasper, checks if it exists already and uses it, If it does not exist, it will compile it and use it.

    Doug

    Post edited by: dmoran, at: 07/05/2006 14:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.