Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: EmailComponent

  1. #1
    Join Date
    Mar 2006

    Default EmailComponent

    I try to send a mail with an attach file(Report create with JasperReport ).I have this error :

    10:19:27,218 INFO [STDOUT] DEBUG: successfully loaded resource: /META-INF/
    10:19:27,234 INFO [STDOUT] DEBUG: !anyLoaded
    10:19:27,234 INFO [STDOUT] DEBUG: not loading resource: /META-INF/
    10:19:27,234 INFO [STDOUT] DEBUG: successfully loaded file: C:\\pentaho-demo\\jre\\lib\\

    10:19:27,234 ERROR [EmailComponent] Error Start: Pentaho build 0001
    10:19:27,234 ERROR [EmailComponent] 4dc79060-d5d7-11da-b6ac-112c9188d6ae:COMPONENT:context-20161192-1146133166046:SendMail.xaction Email.ERROR_0011 - Lenvoi SMTP a échoué : {0}

    java.lang.NullPointerException at org.pentaho.runtime.RuntimeContext.getDataSource(Unknown Source)
    at org.pentaho.component.EmailComponent.executeAction(Unknown Source)
    at org.pentaho.component.ComponentBase.execute(Unknown Source)
    at org.pentaho.runtime.RuntimeContext.executeComponent(Unknown Source)
    at org.pentaho.runtime.RuntimeContext.executeAction(Unknown Source)
    at org.pentaho.runtime.RuntimeContext.executeLoop(Unknown Source)

    Please somebody can help me

  2. #2
    Join Date
    Mar 2006

    Default Re:EmailComponent

    uhmm I haven't messed too much with the email component yet, but my first suggestion would be to use the 1.1.4 demo and make sure the email compent in configured properly under samples/system/smpt-email. and then check out the cases in the bursting folder.

    I hope it helps,

    Try not to have too much fun.
    - - - -
    Nic Guzaldo
    That guy who shows up here
    and there

  3. #3
    Join Date
    Mar 2006

    Default Re:EmailComponent

    thank you for your answer but I have the same error .

    I send you my xaction file .
    I don't know what is wrong .


  4. #4
    Join Date
    Nov 1999

    Default Re:EmailComponent

    Here's what I can recommend:

    a- Look in the server log for the full error. You should be able to see some kind of exception/stack trace in there that will give you more information.

    b- Make sure that you're talking to an SMTP server. In some cases, people have tried to use SMTP to talk to their Exchange server when the Exchange server wasn't configured to support SMTP. The solution here is to talk to your I.S. staff to find out what the actual SMTP server is.

    c- Determine whether your SMTP server requires authentication. Some do, some don't. If you've configured the email configuration without authentication, and it's reall SMTP, it's possible that the server requires SMTP authentication. Please see as an example the gmail version of the configuration file to see how to supply the userid and password for SMTP authentication.

    I hope these steps help,


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.