Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Impact of Incomplete Deployment?

  1. #1

    Default Impact of Incomplete Deployment?

    I am running RC2 and get the following on PCI startup (lots of other errors during startup as well):

    22:04:46,804 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

    --- Incompletely deployed packages ---
    org.jboss.portal.server.deployment.jboss.PortalDeploymentInfo@e5a55755 { url=fil
    e:/C:/java/pentaho-demo/jboss/server/default/deploy/jboss-portal.sar/pentaho-por
    tlets.war/WEB-INF/ }
    deployer: org.jboss.portal.server.deployment.jboss.ServerDeployer@a47962
    status: Deployment FAILED reason: query did not return a unique result: 2; - n
    ested throwable: (org.hibernate.NonUniqueResultException: query did not return a
    unique result: 2)
    state: FAILED
    watch: file:/C:/java/pentaho-demo/jboss/server/default/deploy/jboss-portal.sar
    /pentaho-portlets.war/WEB-INF/
    altDD: null
    lastDeployed: 1160280276670
    lastModified: 1158675472627
    mbeans:

    org.jboss.portal.server.deployment.jboss.PortalDeploymentInfo@bb445e17 { url=fil
    e:/C:/java/pentaho-demo/jboss/server/default/deploy/jboss-portal.sar/pentaho-adm
    in-portlets.war/WEB-INF/ }
    deployer: org.jboss.portal.server.deployment.jboss.ServerDeployer@a47962
    status: Deployment FAILED reason: query did not return a unique result: 2; - n
    ested throwable: (org.hibernate.NonUniqueResultException: query did not return a
    unique result: 2)
    state: FAILED
    watch: file:/C:/java/pentaho-demo/jboss/server/default/deploy/jboss-portal.sar
    /pentaho-admin-portlets.war/WEB-INF/
    altDD: null
    lastDeployed: 1160280276750
    lastModified: 1158675472497
    mbeans:


    What is the impact of this?

    Bill

  2. #2
    Join Date
    Jan 2006
    Posts
    460

    Default Re:Impact of Incomplete Deployment?

    Since it looks like this is portal specific, it is likely that only the portal is affected. We have not heard of anyone having this problem, I have tested this on linux and others on windows without any such errors.

    Is your hypersonic database running? I ask only because I see hibernate complaining.. You are starting the PCI with the start-pentaho script correct? This script should start hypersonic and jboss. Be sure you don't already have hypersonic running. Do you know what version of Java you are running (JAVA_HOME)? The platform requires 1.4+.

    -Mike

  3. #3

    Default Re:Impact of Incomplete Deployment?

    Hi-
    Did you ever find the fix for this? I too am having a similar issue on Windows XP. I have no idea what is causing this. The demo samples also do not seem to load and work. I attached a screen shot incase someone else has experienced this as well.

    Thanks,
    Tiffani http://forums.pentaho.org/archived_a.../demoerror.doc

  4. #4

    Default Re:Impact of Incomplete Deployment?

    Hi-
    Well I just downloaded it again and it seems to be working ok now...so I am not sure what happened.

    Tiffani

  5. #5

    Default Re:Impact of Incomplete Deployment?

    I have solved the problem, but I have found that I can cause the problem by shutting down and restarting too quickly causes the corruption. I think it is a Hypersonic problem. I am going to investigate a bit more and will post what I find.

    Bill

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.