Hitachi Vantara Pentaho Community Forums
Results 1 to 12 of 12

Thread: Cube Designer - Step 6

  1. #1
    Join Date
    Nov 2006
    Posts
    7

    Default Cube Designer - Step 6

    Hi,

    My name is Marcelo, and I'm in Brazil.

    I'm testing the Cube Designer. When I start the "publish" function or "finish" on step 6, nothing happens. The system doesn't respond.

    I guess it maybe some password server, or something like that. Can someone help me?


    Best Regards

    Marcelo Campi

  2. #2
    Join Date
    Nov 2006
    Posts
    7

    Default Re:Cube Designer - Step 6

    Hi there, I've got the same problem: When trying to save my cube the designer just locks up. First I thought that perhaps it won't work withouth pentaho (which I haven't installed) but the readme states that the designer is a stand-alone-app so it should work anyway right? Help would be greatly appreciated.

    best regards

    Chriss

  3. #3

    Default Re:Cube Designer - Step 6

    Hello,

    Most likely you need to configure the Publish Password and re-start your Pentaho Open BI Server.

    Edit your publisher_config.xml file found in:
    \\pentaho-demo\\pentaho-solutions\\system

    Add any password in between the <password></password> tags.

    Restart your server. When you go to publish on Step 6, enter the password you just configured in the Publish Password field. Leave the ServerID and Server password fields blank (unless you are using the Professional edition).

    Hope this helps!

    -Jake

  4. #4
    Join Date
    Nov 2006
    Posts
    7

    Default Re:Cube Designer - Step 6

    Hi Jake,

    I've been looking for some messages in the forum, and already implemented this solution. In fact, it works.

    Now, I've another problem ... when preview the cube, there is a message "JPivot Error ...
    An error happened servicing a JPivot request. Please see the server console for more details."

    Can you help me?

    Regards

    Marcelo Campi

  5. #5
    Join Date
    Nov 2006
    Posts
    7

    Default Re:Cube Designer - Step 6

    Hi Jake,

    so.. I hope this question doesn't sound too stupid but.. looks like I can't run the cube designer without the pentaho BI Suite being installed, right?.. From the readme of the designer I thought it would be a stand alone application and - to be honest - I don't really understand what I would need penatho for if all I want to do is to create a cube-schema and export it to XML. But everytime I click on the "View XML" button the application well.. doesn't respond anymore ..

    Hope you (or someone else) can enlighten me ;-)

    regards

    Chriss

    P.S: the readme lists a running pentaho OR mondrian server as a requirement.. well.. I have mondrian running but that alone doesnt seem to do the trick. Do I have to extract the Cube Designer into a specific directory for it to run or can I choose one as I see fit?

    Post edited by: Chriss82, at: 2006/11/20 16:00

  6. #6

    Default Re:Cube Designer - Step 6

    Hi Marcelo,

    Could you copy/paste the first 5-10 lines of the stack trace(s) you get in the server console? You may need to increase the buffer on the command window in order to scroll all the way to the first error that occurs.

    Thanks,
    Jake

  7. #7

    Default Re:Cube Designer - Step 6

    Hello Chriss,

    Having the Pentaho server installed/running is only a requirement if you want to publish your schema up to the Pentaho server and be able to preview it.

    If you are running Mondrian stand alone and you just want the generated Mondrian schema, just click Finish on step 6 and it will prompt you for the location you want to save the schema to.

    Hope this helps!

    -Jake

  8. #8

    Default Re:Cube Designer - Step 6

    I am still having this issue. Even with the publisher password in place, my CPU just spins up to full and never comes back. Never may be to strong a word. I let it run for an hour and assumed forever.


    However, this only occurs when I make a cube with dimensions. If I make a nice simple cube on a single table, I can hit <finish> and generate my files (xaction, xml and properties). Cannot however, get publish or view to work in any form. I am using a base of RC3 demo for my target.

    Thanks,

    Matt

  9. #9

    Default Re:Cube Designer - Step 6

    Agreed. If I have a fact table and create dimensions based on Fact Columns and measures based on the fact columns then it seems to save. Otherwise, If I join even one dimension table and try to save, I get nothing when I click "Finish" or "Publish". I have changed the system properties XML file as identified in a previous post.

    Bill

  10. #10
    Join Date
    Oct 2006
    Posts
    4

    Unhappy Cube Designer doesn't work

    At step 6 clicking on the preview button nothing append and the cpu goes at 100%. This occurs only for cube with dimension with joins between tables, Pentaho server demo up and running, publish password set and no error shown. I don't know whatelse do.
    Does anyone have an idea to solve this problem?
    Thx in advance.

  11. #11
    Join Date
    Oct 2006
    Posts
    3

    Default

    Pentaho cube designer is still lacking many features, I feel editing the mondrian schema manually is easier than the cube designer.

  12. #12
    Join Date
    May 2006
    Posts
    19

    Default

    Hi!

    I'm having the same problem with Cube Designer: when trying to preview XML the application freezes.

    Does anyone solved it already?

    Thanks...
    NACF

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.