Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Report Wizard & MDX Query

  1. #1

    Default Report Wizard & MDX Query

    I haven't been able to get the report wizard to work with even the most simple mdx query. The trouble starts when I try to move past the Data Source & Query tab. I see two "Connection was Successful" pop-up windows, then nothing.

    I've tried this on Windows XP and Windows 2003 SBE. The database is Oracle. The Mondrian schema is fine, the MDX query is fine, the database is fine, the JNDI data connection is fine.

    So I'm thinking this is a bug, or there is something in even this simple query that can't work with the wizard. Here is the simple query:

    select {[Ledger.Ledgers].[All Ledgers].[Actuals].[Actuals Ledger - 181]} ON COLUMNS,
    {[Measures].[Transaction Amount], [Measures].[Transaction Quantity], [Measures].[Average Transaction Amount]} ON ROWS
    from [GL Posted Transactions]

    It is important to be able to build queries using MDX.



    Post edited by: clavigne, at: 09/13/2006 22:40

  2. #2

    Default Re:Report Wizard & MDX Query


    I'm having the same problem. MDX Queries don't work in Pentaho Report Wizard (as you said) and not in Pentaho Report Designer either.

    I have seen anyway the Report Designer working, but never been able to do it again... maybe it has something to do with the schema (which is working and tested for everything else).

    Javier Giménez
    StrateBI - TodoBI

  3. #3
    Join Date
    Jun 2006

    Default Re:Report Wizard & MDX Query

    I am also experiencing this exact anomoly. See following post..
    My JNDI config is set to connect to Oracle 9i. My query works fine with JPivot as well as my JNDI properties within the PCI. Mike seems to think it has somthing to do with the JDBC URL parameter passing. He said he tried to replicate the problem but was unsuccessful. In the meantime I have been trying to debug RDW but I cannot connect to the SVN repo from behind my firewall. I tried bringing in the source to eclipse but have been unsuccessful. If anyone ever finds out what the problem is I'd like to know.


    "If you want to increase your success rate, double your failure rate."
    Thomas Watson, Sr (former president of IBM)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.