Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: I got a little Problem with a linechart

  1. #1
    Join Date
    Oct 2005
    Posts
    1

    Default I got a little Problem with a linechart

    Hi.

    Today i had to use a Linechart, and i got just a little problem left.

    [img]http://www.schimi-online.de/blog/uploads/linechart.jpg[/url]

    i marked 2 areas there on this chart. this are the areas, i don't want to see.

    is it possible to set the time axis to 0-600 and that it won't display this space on the left and on the top ?


    there is no data in this area, but i can't figure out how to get rid of this space

    Thank you in advance.

    Daniel

  2. #2

    Default

    Each axis has a default margin of 5%, a gap it will leave between the maximum data value and the end of the axis. You can change that using code similar to this:

    Code:
    XYPlot plot = (XYPlot) chart.getPlot();
    ValueAxis xAxis = plot.getDomainAxis();
    xAxis.setUpperMargin(0.0);
    ValueAxis yAxis = plot.getRangeAxis();
    yAxis.setUpperMargin(0.0);
    Dave Gilbert
    JFreeChart Project Leader

    :idea: Buy the JFreeChart Developer Guide :idea:
    :!: Did I help you? Help someone else : WaterAid :!:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.